Jump to content
ypdeveloper

Lenovo z51-70: graphics acceleration for AMD R9 M375 GPU

Recommended Posts

Hello Bronxtech 

I know that the amd gpu not inject at the because i use the dsdt provide from bootpack of z51-70

hence it disble,i dint know how to enable it 

so can you please inject my gpu in my dsdt 

my gpu details are in attached photo

 

post-83658-0-12057800-1456899097_thumb.png

DSDT.aml.zip

Share this post


Link to post
Share on other sites

i would love to help you but, i would not know where to begin unfortunately. the only radeon hardware i have is in a desktop and it works native as in does not need patching.

Share this post


Link to post
Share on other sites

how i can enable amd from dsdt .

because the system not load with amd gpu

or if you know any link of guiding to patch amd than share me

and also my dsdt gives me alot error when i trying to compile it so can you solve my dsdt error and reattach here

than i can try to patch amd gpu

tnx for you help.....

Share this post


Link to post
Share on other sites

Hello jake i try your method and i get following error 

 

RadeonSensors : still waiting for IOAccelerator to start.....

RadeonSensors : still waiting for IOAccelerator to start.....

RadeonSensors (pic 4) : [error] unable to locate ATY,bn_image

RadeonSensors (pic 4) : Found ATI Radeon ID: 0x6820 , BIOS:undefined

RadeonSensors (pic 4) : using device-id to resolve temperature sensor type

RadeonSensors (pic 4) : adding southern island thermal sensor

RadeonSensors (pic 4) :started

[iGPU] Graphics Driver faild to load: could not register with frame buffer driver

 

 

so i think the amd gpu started but the intel gpu is not starting because i remove DSDt so can you please 

enable my amd gpu from your previous dsdt that is attached by you before

 

Don't think that i am a noob person

i just want make all amd gpu workable in hackintosh laptop

so please help me

 

thank

DSDT.aml.zip

Share this post


Link to post
Share on other sites

I again ask to all developers and members on this fourm

Please if anyone know how to inject amd gpu in hackintosh laptop

please help me to solve my issue

 

Hope this time i will get reply 

Thnx

Share this post


Link to post
Share on other sites

Thx @Herve for replying

I want to inform you that i try RampageDev's guide to

Make working Amd Gpu. But im not get success because it require the AMD Vbios for patching framebuffer personality, i extract Vbios with aida64 in window, and Darwindumper in mac but every time i get only one Vbios File which one is for intel hd 5500

So please help me how i can get Vbios rom for amd gpu

 

Please help

So we make this gpu working and help everyone who wants here

Thnx......

Share this post


Link to post
Share on other sites

Try:

ioreg -arw0 -d1 -n display | xpath '//key[.="ATY,bin_image"]/following-sibling::*[1]/text()' | base64 -D -o ~/Desktop/vbios.rom

(if required, replace "display" with your own AMD-related device as shown in IOReg - GFX0 or PEGP for instance).

 

Courtesy of SJ_UnderWater.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...