Jump to content

eraydin

Recommended Posts

I got the OS work now~ Thank you for your guide.

1 more question for the airportd

 \usr\libexec\airportd

I cannot find that path

so where should I put the airports

 

============================

ok Got it too. It is a hidden folder. SO have to use the showhiddenfiles.app

However, I still don't see the wifi option in System preferences-Network

I cannot get the wifi work.

Could someone help me please?

Link to comment
Share on other sites

And, the display keep flickering on browser, pictures and some of the apps 

How could I fix that??

 

=================================

 

OK I know why it happen

I am using intel HD4000, so I used this in my config before

<key>device-properties</key>   <string>7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000005006201140000006800640061002d0067006600780000000d0000006f6e626f6172642d31</string>
 

Now I removed that string and don't install the AppleIntelFramebufferCapri.kext. It works fine now. So I think intel HD4000 do not actually need this string.

 

Now trying to get wifi working

 

My laptop is Asus K55A   i7-3610QM intel HD4000 Graphics

Link to comment
Share on other sites

prepared usb with myhack but stuck at grey screen when i boot from usb...

 

i want to know how did you update your bios...i am afraid if something goes wrong i might brick my laptop...

1.did you take backup of your old bios[if yes,how?]

 

2.did you use easy flash from bios->advanced [i cannot select mine its greyed out]

 

3.did you use win-flash from windows? [i heard that bios update using win flash in windows on newer laptops leaves bricking it]

 

4.is it worth updating to new bios[fan speed etc]

 

finally i cant seem to go past grey screen while installing os x maverics...are there any other method to install..

 

can i dual/triple boot os x/windows 7/linux?

 

i really want to install mavericks hope u'll help in this regard,

 

ok i updated my bios to 211 but most of the options are greyed out....how can i access those options?

thank you :)

 

After I followed this guide, I got success installation of OSX on my ASUS K55A. 

Thank you for the this guide and members.

Now, I am trying to install triple boot too. We really need a guide for it.

I google UEFI triple install, then follows some guide on other forum. But I failed on it =( 

Link to comment
Share on other sites

I did not use myhack to make my bootable drive.
here is my step and work for me.

Step1:Disk utility -> partition tab -> change "current" to partition 1.
Option -->GUID
Name it "USB". --> format Mac OS extended (journaled)
--> apply --> partition

Step2:Open terminal type:

sudo /Applications/Install\ OS\ X\ Mavericks.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ Mavericks.app --no interaction

Wait until it say "done" it may take 10 to 15mis
[i dunno Step 3 is necessary or not, but it works for me. I am newbie too. Please point it out if any step is not necessary thanks]
Step3: download Clover and open it
http://sourceforge.net/projects/cloverefiboot (chameleon, stolen and rebranded)/

Continue -> continue -> change install location -> select " install OS X Mavericks"
Customize -> trick Install for UEFI -> theme : Bootcamp -> Drivers64UEFI: EmuVariable OsxAptioFixDrv PartitionDxe
Then "install". After install you will have a EFI driver.
Download the Clover EFI 2636 2.3.14.zip in this post first page
Copy the "EFI folder" inside Clover EFI 2636 2.3.14 to the EFI driver. Replace All.
go to the "Apps folder" inside Clover EFI 2636 2.3.14, open Showhiddenfiles app --> hit "Show special files".
Now copy all kexts of efi/clover/kexts/10.9 into OS X Install USB/System/Library/Extensions and replace
Then bootable USB is done. I can use it.
Then go back the first page of this post and follow the rest.

*Don't install AppleIntelFramebufferCapri.kext

-----------------------------------------------------

If you success to install the OSX, but you don't see the bootloader after restart.
Is this your problem? If yes see below,
You open the config that inside the "CLOVER" FOLDER in your EFI driver.
and search the "time out". change 0 to 10.
<key>Timeout</key>
<integer>10</integer>

Link to comment
Share on other sites

Ok. I got my windows work now. 

Here is my steps: 

you need to make a bootable UEFI USB Drive for windows (Use option one) 

(If you don't know how to make, google "UEFI Bootable USB Flash Drive - Create in Windows" (first link Use option one) 

 

First, you have to partition Mac OSX Extended / Freespace to split the drive before install OSX.

(You could not format fat/exfat in here, otherwise, The partition would mess up with Hybrid MBR. it cannot install windows)

After you install OSX following this guide,  insert the windows USB and restart.

Choose windows at the bootloader.

Then,install Windows in the partition which you format before.

 

Then, you can see it in clover bootloader after finish installation.

 

===================================================================

For ubuntu,

make a bootable ubuntu disc or USB.

Set Boot Device to USB/Disc

Install ubuntu --> Continue until "Installation Type" then select  "something else"

press "+" --> Create partition --> make a 2048MB partition use as swap

press "+" --> Create partition --> make you system partition use ext4

Device for boot loader installation -> (use the same one as the system partition)

Install.

Restart and set back your first Boot Device as Clover EFI (/EFI/CLOVER/CLOVERX64) in BIOS.

Then, your bootloader would able to see the Ubuntu. DONE

Link to comment
Share on other sites

thank you but my bios wont boot uefi usb[created uefi bootable usb using .........#sudo /Applications/Install\ OS\ X\ Mavericks.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ Mavericks.app --no interaction] but whenever i tried to boot from uefi bootable usb, system directly goes to my windows 7...
thats why using myhack...
im currently stuck at pci configuration end line
things i have tried,
1. -x -v
2.PciRootUID=1 - x -v
3.npci=0x2000 -x -v
4.npci=0x3000 -x -v
5.GraphicsEnabler=No -x -v
but with all the still stuck at pci configuration end :(

here is the screenshot14yacs4.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...