Jump to content

Refined ALPS TouchPad driver

Dr. Hurt

Recommended Posts

On 10/25/2018 at 10:34 AM, Jake Lo said:

You mean this?


Try re-compiling from Mojave


I suppose yes. I've downloaded the kext from this forum first page.


Tried to recompile the original project (link above) on Xcode 10 Mojave, but got errors, and I don't have skills to manage then.


error: Build input file cannot be found: '/Volumes/Macintosh HD 2/OS-X-ALPS-DRIVER-Release-6-WIP/VoodooPS2Mouse/VoodooPS2Mouse-Info.plist'


macOS Deployment Target: 10.12

Project Format: Xcode 10.0-compatible


Link to comment
Share on other sites

On 10/27/2018 at 9:21 PM, Jake Lo said:

Try this. Compiled by Bronxteck from Mojave with latest Xcode


Thank you, but that kext does not work on my laptop/ALPS V8 device, like happens with previous Bronxteck's compilation (Sierra/High Sierra).
There is no cursor movement, exactly as the previous one.

There is click and right-click (Option-click).

The keyboard works, but the Caps-Lock light keeps on, whatever the mode used.

Link to comment
Share on other sites

  • Administrators

So nothing new: ALPS v8 remains poorly supported, no reason why this would have changed when the code has not...


On the other hand, the kext, as previously compiled, works without issues on my E6220, E6230 or E6440 under Mojave. I've not had to use a Mojave-compiled version.

  • Like 1
Link to comment
Share on other sites

On 10/29/2018 at 7:41 PM, Hervé said:

On the other hand, the kext, as previously compiled, works without issues on my E6220, E6230 or E6440 under Mojave. I've not had to use a Mojave-compiled version.


I honestly envy you now. I actually like this driver the most of all that I tried, but it doesn't work as expected on my system. I have few questions.


1. Can you please confirm that you do not have any problem with caps lock LED? On my system, once LED is turned on (first time when I press caps lock), it can't be turned off. It's very annoying when I do not know if my caps is turned on or not.


2. Is there a way to make cursor moving faster? It's too slow for my taste. It's almost twice slower than with ApplePS2Controller. Can I change anything in plist to make it faster?


3. Is there any way to make PrtScr and Insert keys to work? I need those two keys, but they are dead on my system. Karbiner EventViewer doesn't register a keystroke when I press any of them. I am using VI editor a lot on linux servers so I absolutely need this key. I am using PrtScr to initiate a screenshot with Karabiner complex modification. Can I activate those dead keys with some change in plist or code change + recompile is needed?


4. How can I find my APLS version?


5, Does any complex gesture works for you? For example, 4 finger gesture like Pinch to restore.




I have v7 version.

2018-11-01 22:58:50.637303+0100 0x100      Default     0x0                  0      0    kernel: (kernel) ALPS: Found a V7 TouchPad with ID: E7=0x73 0x03 0x0a, EC=0x88 0xba 0x2a
2018-11-01 22:58:50.678168+0100 0x100      Default     0x0                  0      0    kernel: (kernel) ALPS: TrackStick detected... (WARNING: V7 TrackStick disabled)
2018-11-01 22:58:50.678172+0100 0x100      Default     0x0                  0      0    kernel: (kernel) ALPS: TouchPad driver started...


Link to comment
Share on other sites

Even with trackpad speed set to maximum in preferences, cursor movement is still too slow for my taste. I need to swipe my finger at least 2 times to accomplish same cursor movement as with one swipe with ApplePS2Controller. Do you have any idea what I could try to change in Info.plist inside trakpad kext?


Apple keyboards do not have those keys, thats not questionable (I have one on my table right now). I am just not sure why those keys are disabled in this kext. They work just fine with ApplePS2Controller. Everyone would benefit with two more working keys. People could change those to anything they want with Karabiner-Elements, but they are currently completely dead. I hope that there is a simple way to enable them by changing Info.plist inside keyboard kext, and that there is no need for code modification.


PtrScr key is mapped to Shit+Command+4 and Insert is mapped to Home with ApplePS2Controller, but I would be satisfied with any two codes that Karabiner could see.


Link to comment
Share on other sites

On 2/13/2017 at 7:50 PM, Bronxteck said:

just checked Herve. yeah no plugins just container. hence no trackpad or keyboard kext inside. forgot to check lol.


recompiled from source on post 582


This kext works on my E5250 I can see touchpad gestures in settings but it has some problems

"Sometimes jumps when scolling with two fingers"

"Only 3 and 4 finger swipe up (other directions are not working)gestures works"

"Pinch in-out gestures not working 

"And cursor jumps sometimes"

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...