Jump to content

Dell Latitude E6220


Recommended Posts

I try on a machine with BIOS A08. restart fix is there in the boot.plist.


I notice that when I wait for long enough time, it will shut down.


PS. I take out the bootpack DSDT and replace with an extracted DSDT.aml by using DSDT Editor.



Sleep function works perfectly. Just like what it behaves in Windows


Only Shutdown and restart have this problem

Link to comment
Share on other sites

  • Administrators

I think we needed to update the DSDT for that model, i think the current one was based on a older bios update.


However, for now.. there is a few things you can try.


1. Remove/replace battry and lan kexts

2. Google around and play with the OpenHaltRestart and EvOreboot kexts.

Link to comment
Share on other sites

Hi there, i have the e6220 bios a08, 8GB ram, Samsung P830 128GB SSD, i5 2520M, wifi i replace with Dell 1515, i use the myhack to create the USB for mountain lion. after boot up it shows:


"EBIOS read error: Controller or Device error

Block xxxxxxx Sectors 0"


for 5 times than follow with "/" only.


If i use the -f it will show the same error as above too.

If i use the -v it will show many texts and reboot by itself. Text scroll too fast i cant read anything at all.


I try search in google but show me is media fault so i make a few more USB to test but all gives the same error as well. I also try to disable all the unwanted stuff in BIOS in the misc field but still same.


If need more info please tell me I will get it or screenshot it.


I really want to run mac on this laptop, please kindly help me out here, thanks in advance.

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...