Jump to content
micheajp

Dell Latitude 7490 - Mojave

Recommended Posts

hi, I read all posts that I can find regarding Latitude 7490 ( with the Micron 256 GB SSD).

I also bought a Dell Latitude WiFi Card 0VW3T3 DW-1820A

I followed the install guide from Herve, same picture here with the files 6 and also 7 I got KP.

I renamed DSDT and I was able to install Mac OS.

But it is still not fixed with the version of 7 of the files.

 

 

Share this post


Link to post
Share on other sites

if Herve's DSDT did not work for you then you are most likely on a different bios revision then the DSDT  he supplied in the boot pack was made with.

Share this post


Link to post
Share on other sites

With the revised DSDT posted last Sunday, yes. But if it still fails for you for some reason, you can bypass it by opting for "BIOS.aml" as DSDT name in Clover's Options->ACPI patching menu available from the main menu at startup.

 

The DSDT is only patched for Fn-F11/Fn-F12 brightness control and I've posted all the details of the patch, so folks can patch their own extracted DSDT if desired.

 

Share this post


Link to post
Share on other sites

@micheajp I got the same problem with HDMI port, when it was connected to my TV, all was in some "pinky" colors. What I made It was just adding connector to graphic configuration in Devices/Properities. But a resolution remains stil the same. But I believe Devices/Properities is the place where you should looking. I'm also almost sure, that my connector configuration added is not fully proper. Maybe someone will be able to say what is wrong. SS's from Hackintool and Devices/Properities attached.

P.S.
When I set other value for con1-type, I get black screen. When delete con1, I have a "pinky" screen on tv.

Zrzut ekranu 2019-09-15 o 20.30.25.png

Zrzut ekranu 2019-09-15 o 20.31.06.png

Zrzut ekranu 2019-09-15 o 20.33.17.png

Zrzut ekranu 2019-09-15 o 20.33.28.png

Share this post


Link to post
Share on other sites

@MatiWaldi  Personally only have the tint issue on HDMI with a TV.   For the screen res, I've tried changing EID manually, I've tried hackintool.  I still cannot get the machine to respect the aspect of my monitor.   

 

HDMI or USBC, doesn't matter.  I pulled the info from windows, which of course goes full screen perfectly.  I'm also now getting a dump if I leave it overnight, so I reboot daily.  When it comes back from sleep the USB Dell dock's NIC is DOA and reseating doesn't work, just a reboot.   @Hervé maybe you can look at it?  Am i changing the EDID correctly?  I attached clover, monitor info and the dump file for your inspection.

 

This screen is immediately after my AM boot, as this is my daily driver. 

 

CLOVER.zip

 

Model is correct, specs are ignored.  Ram tune is correct. 

 

image.png.cf344b41afd7da3772a6bf60bd7cff0f.png

 

 

Profile matches. 

 

image.png.617fa58506bf22d750b2d517320e6cf9.png

 

From Windows

 image.png.306ec22a5b946b240f8866fb0779a5cf.png

 

Injected data 

 

image.png

eficheck.dump.zip monitorInfo.zip

Share this post


Link to post
Share on other sites

Your Clover graphics settings appear quite incorrect... Where did you get them from, especially that 4K patch ( 🤪 ) ?

 

Clover_boot.jpg

 

Clover_Devices.jpg

 

Clover_Graphics.jpg

 

Clover_Patches.jpg

 

Share this post


Link to post
Share on other sites

These are all attempts to use the original documentation. I can remove all that and it won't matter.

This one is part of the original bundle.

 

image.thumb.png.d122df10cc998f96f9a12f096b6f35fc.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...