Jump to content

DW1820a - the general troubleshooting thread


Recommended Posts

@nickhxAmazing. Work with my build.

The BrcmBluetoothInjector.kext doesn't seem to be included in bitbucket pack. Did you built them on your own? I looked into the plist and they were built on macOS 10.14.

Also, RehabMan mentioned "Do not use any of the other kexts (BrcmPatchRAM, BrcmPatchRAM2, BrcmFirmwareRepo, or BrcmFirmwareData) with this kext.", but apparently we need to combine them together.


Again, amazing job.

Link to comment
Share on other sites

Thanks credit to @headkaze for the updated brcmpatchram kexts for Catalina, which I am using as a base here.


 I have made some changes to the underlying code which I am still testing to deal with the patching issue.


How Did you get your Apple Watch unlock consistently working (I have seen your other post but replicating those settings only enables me to unlock once).  Also does personal hotspot via handoff work for you (clicking iPhone hotspot connection in WiFi menu without hotspot being on or phone connected via Bluetooth).

Link to comment
Share on other sites


1 hour ago, nickhx said:

 I have made some changes to the underlying code which I am still testing to deal with the patching issue.


May we know what issue you are referring to?


Also could you share a bit of your knowledge why you are using a combination of 3 of these kext? as rehabman usually recommends a combination of either an injector or patchram, but not both together.. 

Link to comment
Share on other sites

Issue is the patchram function not initialising the Bluetooth chip correctly.


BrcmBluetoothInjector.kext is required for conpatability with Catalina (but also works with Mojave).  If you delete it, then it will not work. 

Link to comment
Share on other sites


I have thinkpad T440p and I have dw1820a:


image.png.7fa8e5d5715a04fb363b17d6e5fc8bad.pngScreen Shot 2019-08-06 at 15.07.46


I followed @Hervés guide (clover inject) first. In Windows, device properties in device manager shows:

Location Paths:



(no BIOS Path in the options)





I can't boot without:

1) brcmfix=1 in boot arguments

2) airportbrcmfixup.kext in c/k/o


When checking FixAirport and AddDTGP in ACPI Fixes:




This path shows up: (without FixAirport and AddDTGP checked, only EXP1@1C shows up, which I think is the cardreader at least according to hackintool)









In system report:




Only put airportbcrmfixup.kext in /c/k/o, if Install it in /L/E I can't boot. Here are /c/k/o kexts: (i just tried adding BroadcomWiFiInjector.kext and FakePCIID_Broadcom_WiFi.kext because I thought clover is not properly injecting all data in the properties tab):





Please help. Been trying to fix this for 3 days and I'm stuck. Tried different combinations including trying other SMBIOS settings, trying different paths in devices properties (PciRoot(0x0)/Pci(0x1c,0x01)/Pci(0x0,0x0) to (PciRoot(0x0)/Pci(0x1c,0x1)/Pci(0x0,0x0) .... (PciRoot(0x0)/Pci(0x1cx0x0)/Pci(0x0,0x0) ... etc.


If I try (PciRoot(0x0)/Pci(0x1c)/Pci(0x0,0x0) clover injects the data properly into this address (cardreader) except the 'compatible|pcie14e4,4353', model, name, device_type are on point.. which is weird..


I can't seem to DSDT patch smoothly (I have tried before but I get too many errors) that's why I didn't try patching this.


Any help/suggestion would be greatly appreciated. 


PS: I have a SSDT patch in my patched folder from a guide, without this I have no battery manager and brightness adjustment.

Link to comment
Share on other sites

@menomac I am in almost same situation with you.

Bought a DW1820a card OVW3T3 but with ID 1028:0023 (not 0021 as expected) and unmatching MAC address.

The wifi part work out-of-the box in Dell 3040 micro, without any patch and kext. Bluetooth need firmware loader as usual.

When I used the card in Thinkpad T440s (BIOS ver 2.36), Windows part works fine, without any problem. But Mac OS (High Sierra 10.13.3) can not boot to desktop, it stuck forever at about 70-80% of boot. Patching PCI property nor various kext manipulations nor disable pins using adhesive tape can not help the T440s to boot into OSX. It took me whole weekend to fight with the problem.

Then I found this blogspot (in Chinese). The author said that his method do not require to disable pins on the card. Using the attached file, the procedure is as follow:

1. To make the computer to boot to OSX temporary: put the kexts in Clover folder in attached file to Clover/Kext/Other (or 10.13 depending on your system). If the computer still can not boot, then go to BIOS -> Security -> IO Ports and disable Wifi, WWAN and Bluetooth.

2. After booting to OSX, open Airport folder (in attached file) and run _install_airport.command to install some kexts to S/L/E and L/E. Note that for this step you will need OSX 10.13.6 (I had to upgrade from 10.13.3 because the kexts were compiled in 10.13.6). 

After that, my T440s start working, almost fine, with AirDrop. But sometime it crash (KP) when booting or shutdown. Bluetooth shows firmware 5799 but works intermittently, still need firmware uploader by Windows.

Yesterday, I saw @nickhx post in the previous page (thanks to him) and install his kext and  after using his method (for the bluetooth part), the bluetooth works almost properly without the need to load firmware by Windows.

Two problems still remain:

- The system sometimes have KP on boot, and frequent KP on shutdown.

- Bluetooth PAN network doesn't work, despite successful connection by bluetooth to IPhone. See pictures below.


@Hervé Do you have any hint for me to fix this Bluetooth PAN problems?

Screen Shot 2019-08-06 at 20.17.41.png

Screen Shot 2019-08-06 at 20.17.29.png


Link to comment
Share on other sites

  • Administrators

If you experience KP, there's a high chance that you've reverted to an older wireless kext from Yosemite. It's actually a bad idea and, given the impact, it is simply not sustainable. If you cannot get your DW1820A to work, demand to return it to the seller especially as the MAC@ does not match the label... It's a fake OVW3T3.


Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...