Jump to content
micheajp

Dell Latitude 7490 - Mojave

Recommended Posts

Thanks for the guidance @Jake Lo @Bronxteck @Hervé

 

Need further help, as I'm starting to notice the severe performance degradation linked to DW1820A CN-08FKP4. The card I installed is the correct recommended model (0VW3T3), according to the sticker on the card at least. Is there possibly another reason for the wifi and performance issues related to this card? or is there another way i could confirm from the system that the card i received is indeed the correct model?

 

10-15 minutes into login, the system slows to a crawl and force reboot is the only way out. This happens consistently as well. 

 

In the mean time i'm gonna try and fix bluetooth first. Any advise would be much appreciated too

Share this post


Link to post
Share on other sites

I didn’t experience the WiFi slowdowns. Maybe it’s random with that card. 

 

Anyone have time to look at a 4K monitor issue?  @Hervé this has been my daily driver for two weeks. It’s going well. 

Share this post


Link to post
Share on other sites

do you have at least bios update 1.6 there was a turboboost fix and processor states update at that revision. latest version as of writing is 1.9.3

Share this post


Link to post
Share on other sites

Fantastic work! My touchpad works well now.

But...My BCM94352 broken after using your kexts.

I tried to pull my old BCM drivers to kexts but it did not work maybe as FakePCIID cannot be load...

Share this post


Link to post
Share on other sites

Hi all. I've been using the machine daily for a couple weeks, traveled with it. Fantastic. Even has decent battery life.  I need to fix the display brightness buttons, but that's it functionally.

 

Still have the issue of the large monitor however. I've tried the hotpatches etc from the various sites. Any ideas on how to get my high res running?

 

Thanks, JM

 

 

Share this post


Link to post
Share on other sites
On 6/7/2019 at 1:15 PM, Hervé said:

They're not "broken"; they're not currently supported by the I2C drivers we use.

 

Hi there! I've installed Karabiner elements software to resolve this issue. And I've got some results.
1. There is possible to remap keyboard keys as touchpad keys. For examle Right Alt and Right Control remap as left and right mouse button. And it works! (See Fig.1)
2. Karabiner can modify events from touchpad. When this feature is on TrackPoint works correctly. Touchpad buttons work correctly (or sometimes they swap). Touchpad surface doesn't work correctly, cursor make fast and chaotic movements. (See Fig.2)

 

 

Karabiner is  an open source software  available here: https://pqrs.org/osx/karabiner/

 

Fig_1.png

Fig_2.png

Share this post


Link to post
Share on other sites

I know the topic states 7490, I have a 7390 (Core i5, 8GB, no touchscreen, FHD), is there much of a difference between the two models? I've tried the guide here on this forum, however the Clover USB does not show the install partition (MacOS Mojave 10.14.5) (MacOS Install on SSD) while booting. Other stuff (battery and keyboard) work fine.

 

I can't seem to understand why the disk is not showing in Clover. I followed the entire guide. It feels like there is something wrong with APFS or HFS+ (tried both) or the apfsdriverloader-64.efi or even the config.plist (tried newest clover as well). The BIOS is 1.9.3 and disk set to AHCI. Secure boot off, etc.

 

I know the Intel WiFi does not work (plan to swap that out once MacOS works).

 

(not trying to hijack this topic, just a push in the right direction)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...