Jump to content
PayPal donations: [email protected] ×
muttonhead411

DW1820a - the general troubleshooting thread

Recommended Posts

Many many thanks for updating and all Your trying and working!! 👍👍👍

 

What I can say about it:

 

At my HP Notebooks (Envy 13, 6th Gen. Intel-CPUs) Pin-Masking worked when macOS activated WIFI.

But mostly device can't get activated when pin-masked.

 

At a Lenovo Yoga card works without issues.

Share this post


Link to post
Share on other sites

@Hervé @Jake Lo @Bronxteck @muttonhead411

 

Do You maybe know a way to force WIFI-card activation at macOS?

Because when masked, card works perfect.

But at 95% macOS does not activate it ...

 

P.S.: Linux always activates the pin-masked card. but after worm reboot macOS mostly deactivates WIFI again.

Share this post


Link to post
Share on other sites

No idea; we'd have to know what each of those masked pins normally do and I don't.

 

Share this post


Link to post
Share on other sites

So, pin masking would affect:

  • pins 51/53/55 at the front
  • pins 54/56 at the rear

 

Share this post


Link to post
Share on other sites

51/53/55 are tied together to ground so probably device / manufacture specific key functions

54- is usb_otg_oc# (this looks to be USB on control) 3.3v input signal from motherboard to socket turns usb off

56- is w_disable#  (this looks like wlan control) 3.3v input signal from motherboard to socket turns wlan off

Share this post


Link to post
Share on other sites

Masking pin worked for 1023 model. 1 bug although Band 36 is not showing in wifi for 5ghz on mac. for windows it's working fine. Bluetooth is working fine. 3rd day already cheers 

Share this post


Link to post
Share on other sites

So, if i am right, masking pin 56 should prevent macOS to disable WIFI.

At my HP seems to be another possibility to disable it, because when enabled at linux and worm reboot device is disabled again ...

Share this post


Link to post
Share on other sites

Hi everyone, just re-purchased the correct 0VW3T model and everything works now, even until now i'm using AirPortBrcmNIC driver, but the wifi sometimes disconnect from 5Ghz to 2.4 Ghz, because i broke the NGFF antenna connector, but it's ok though, shutdown, sleep, wake restart OK, wifi still works, Airdrop, handoff, but sometimes DW1820A wont connect to Instant Hotspot, cheers.

 

also yesterday i watched movie for 4 Hours and no sudden freeze, kernel panic, or cpu usage increase.

 

P.S : i used the pin mask fix from @DalianSky WORKS Great for me, using Acer swift 3 notebook 😂

Screen Shot 2019-08-31 at 23.53.37.png

Screen Shot 2019-08-31 at 23.28.53.png

Screen Shot 2019-08-31 at 23.56.09.png

Screen Shot 2019-08-31 at 23.53.41.png

Screen Shot 2019-09-01 at 00.01.41.png

Share this post


Link to post
Share on other sites

@riskyrismawan, you forgot to specify the boot parameter you're using with AirPrtBrcmFixup, if any at all. If you're not using any, what's the purpose of AirportBrcmFixup since BCM4350 14e4:43a3 is natively controlled through AirPortBrcmNIC kext?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...