Jump to content

Recommended Posts

I don't own this model, but for El Capitan, it's necessary to add that additional patch as I mentioned earlier.

I looked at the bootpack from OP. I made the modification to the config file. Please try to see if it works.

Install the dummy kext ALC270HDA from OP to /S/L/E or /L/E and repair permission

sudo chmod -Rf 755 /L*/E*

sudo chown -Rf 0:0 /L*/E*

sudo chmod -Rf 755 /S*/L*/E*

sudo chown -Rf 0:0 /S*/L*/E*

sudo touch -f /L*/E*

sudo touch -f /S*/L*/E*

sudo kextcache -Boot -U /

I still without sound. I've installed alc270.kext in s/l/e and repaired permissions and nothing. Also I've deleted original AppleHDA.kext from s/l/e. I tried voodoohda also without success.  :(  :(  :(

Link to post
Share on other sites
  • Replies 675
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Here the kext to enable HDMI audio under 10.9.4   Thanks to Jake Lo for it.   http://www.mediafire.com/download/p84asul1cc01jo9/AppleIntelFramebufferCapri.kext.zip

Yes i use the version12.5 of ssdtprgen, where add -w 3 ? clover ? how ?   If I use the last appleacpiplaform patch, all states  ( no sound with appleHDA ) if I use appleacpiplaform, just the state

@dimak08,  In a week we will have this system in our EDP. You can install easily then. The DSDT file is included.

Posted Images

  • Moderators

Check to see if it's loaded. Launched Kextwizard, under Loaded tab, search for 'AppleHDA'

You should see AppleHDAController and AppleHDA

  • AppleHDAController should show version 272.50
  • AppleHDA should show version 999.1
Link to post
Share on other sites

i've found the problem,  when i run the last line in terminal, show this:"Untrusted kext ar not allowed. dummyalc270. kext has invalid signature.  omitting" 

Im searching to resolve this

Now i have the dummy load but i have no sound yet

I see in "about mac"  all input and output but not in preferences of system

 

 

Finally i got sound,  only thing i wonder if you kown Jake is how can i get external output,  i see the option on "information of system"  but when i plug in nothing happens 

Link to post
Share on other sites
  • Moderators

Looking at your bootpack, you need the following added for HDMI audio

in DSDT under HDEF, add this

                    Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method                
                    {
                    Store (Package (0x08)
                        {
                            "built-in", 
                            Buffer (One)
                            {
                                 0x00                                           
                            }, 


                            "layout-id", 
                            Unicode ("\x03"), 
                            "hda-gfx", 
                            Buffer (0x0A)
                            {
                              "onboard-1"
                            }, 

                            "PinConfigurations", 
                            Buffer (One)
                            {
                                 0x00                                           
                            }
                        }, Local0)
                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                    Return (Local0)
                }

Also need to patch the FB with this. Add to KextToPatch in Clover Config

<dict>
<key>Comment</key>
<string>HDMI-audio HD4000 0x01660003, port 0205</string>
<key>Find</key>
<data>
AgUAAAAEAAAHBAAA
</data>
<key>Name</key>
<string>AppleIntelFramebufferCapri</string>
<key>Replace</key>
<data>
AgUAAAAIAAAGAAAA
</data>
</dict>

If the above doesn't work, it could be your system has HDMI on a different port, then try these instead

<dict>
<key>Comment</key>
<string>HDMI-audio HD4000 0x01660003, port 0304</string>
<key>Find</key>
<data>
AwQAAAAEAACBAAAA
</data>
<key>Name</key>
<string>AppleIntelFramebufferCapri</string>
<key>Replace</key>
<data>
AwQAAAAIAAAGAAAA
</data>
</dict>

OR

<dict>
<key>Comment</key>
<string>HDMI-audio HD4000 0x01660003, port 0406</string>
<key>Find</key>
<data>
BAYAAAAEAACBAAAA
</data>
<key>Name</key>
<string>AppleIntelFramebufferCapri</string>
<key>Replace</key>
<data>
BAYAAAAIAAAGAAAA
</data>
</dict>
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...