Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation since 09/20/19 in all areas

  1. 7 points
    Last update: 17 Jun 2020 Target macOS release: Mojave 10.15.x This is a Clover-based installation using the well-known/well documented vanilla method detailed below: Working: full graphics acceleration on Intel UHD620 iGPU, including brightness control (with Lilu v1.3.8 + WEG v1.3.2) multi-display with HDMI OOB, including HDMI-to-DVI adaptation (HDMI-to-VGA not successful) and VGA/DP over USB Type-C audio, including HDMI, microphone input and headset output (with AppleALC v1.3.9 & layout 11 + CodecCommander v2.7.1) GigEthernet LAN connection (with IntelMausiEthernet 2.4.0 kext) wireless and bluetooth with any compatible card (a DW1820A in my case) left and right USB ports (with Hackintool-generated USBPorts), including USB Type-C integrated webcam (OOB) CPU power management sleep (Lid, Energy Saver settings, Apple menu, Fn-Insert, PWR button) & wake (Lid, PWR button) battery management (with ACPIBatteryManager v1.90.1) keyboard (with VoodooPS2Controller v1.9.2) touchpad (with VoodooI2C v2.1.4 + VoodooI2CHID v1.0), including tap-to-click (mandatory in PrefPane settings), scroll & zoom, rotate or other multi-finger gestures. On occasions, won't work until system is rebooted one or several times. RTS525a microSD card reader (Performance limited to 5MB/s) Not working: Touchpad buttons TrackPoint 1) 10.15 USB installer creation Using a USB key of 8GB minimum, create a Catalina USB installer through the following Terminal command: sudo <path>/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/<USB key> where: <path> = location of Catalina installation package (eg: /Applications if freshly downloaded) <USB key> = name of formatted USB volume (eg: USB_8GB) The process will take several minutes. Once completed: install Clover bootloader on the USB installer with the following customised settings: Clover for UEFI booting only Install Clover in the ESP UEFI Drivers Recommended drivers ApfsDriverLoader AptioMemoryFix AudioDxe DataHubDxe FSInject HFSPlus SMCHelper Human Interface Devices Ps2MouseDxe UsbMoueDxe File system Drivers Fat Additional Drivers NvmExpressDxe PartitionDxe Themes (optional) Install Clover Preference Pane (optional) you may use version r5093 attached below: Clover_v2.5k_r5093.pkg.zip once Clover is installed, launch Clover Configurator app and mount the freshly created EFI partition of the USB installer Clover Configurator.zip open this EFI partition and transfer/copy the files & folders from the Latitude 7490 Catalina Clover pack below to the EFI/Clover folder: 7490_Catalina_Clover_Pack.zip 7490_Catalina_Clover_Pack_#2.zip 7490_Catalina_Clover_Pack_#3.zip 2) 10.15 installation boot the Catalina USB installer at the Clover main menu, select the "Install macOS Catalina" partition (but don't press [ENTER]) press [SPACE], select -v verbose option in the menu, then choose to boot with the selected options proceed with installation, creating & formatting the target Catalina installation through Disk Utility as/if required on 1st reboot, boot off the USB installer and select the freshly created "macOS install from <target Catalina partition>" repeat this until this partition is no longer offered and only the target Catalina partition is left to boot Reboot the target Catalina partition via your USB installer 3) Post-installation tuning Once the target Catalina partition has booted, complete the 1st boot configuration tuning Once at the desktop, install Clover bootloader on the Catalina partition/disk with the customised settings listed above Once Clover is installed, launch Clover Configurator app and mount the freshly created EFI partition of the Catalina partition/disk Open this EFI partition and transfer the files & folders from the above Latitude 7490 Catalina Clover pack to the EFI/Clover folder You may then reboot and verify that Catalina boots off your disk through Clover Edit: 02 Nov 2019: - - - - - - - - - - - - - Revised Clover pack #2: DW1820A properties injection commented out (only required for those who have such a card, in which case, remove the # character) Edit: 20 Apr 2020: - - - - - - - - - - - - - Added a note about solution for Realtek RTS525a SD card reader. Edit: 17 Jun 2020: - - - - - - - - - - - - - Revised Clover pack #3: Moved patched DSDT out of ACPI/patched folder since it's causing KP for most people. It was only patched to support brightness control through Fn-F11/Fn-F12. Jake Lo has provided SSDT alternatives in other guides/threads so it's best to use that. I'll try them asap on the 7490 and update accordingly.
  2. 6 points
    OPENCORE Here's a WIP bootpack for those who want to try OC Just replace the entire EFI folder Make sure to have a bootable USB ready incase it doesn't work for you or create a Fat32 USB drive and add the EFI folder to the root. OpenCore v0.5.9 HP840G3_OC.zip Update: Improved touchpad gesture functions: Zoom, left & right swipe, scrolling, etc... Big Sur ready OpenCore v6.0 HP840G3_BigSur_Beta4.zip
  3. 5 points
    Catalina Catalina Guide Bootpack Replace into /EFI/Clover after you install Clover E7470_Catalina.zip E7270_Catalina.zip - For Discrete Model Also add this to /EFI/Clover/ACPI/Patched SSDT-Disable-DGPU.aml FYI, kexts in bootpack might be outdated Make sure to 1st upgrade kexts found under /EFI/CLOVER/kexts/Other if you encounter issue Common links for new kexts: https://github.com/vit9696/Lilu/releases https://github.com/vit9696/Lilu/blob/master/KnownPlugins.md https://bitbucket.org/RehabMan/ Note: 1) Post Install: Copy kexts in /EFI/Clover/kexts/Other/CopyToLE to /Library/Extensions. Repair permissions and rebuild cache 2) Enable this patch in Config.plist under KextsToPatch if you have: LiteOn, Plextor, or Hynix NVMe Hynix NVMe patch 10.13.x (Bit swap block size 0x10) -Syscl Finally we have support for SD Card reader (Realtek RTS525a). See here for more info and link to kext UPDATES Catalina 10.15.1 (19B88) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: INSTALL LATEST CLOVER / UPDATE KEXTS PRIOR TO UPDATE REPAIR PERMISSIONS AND REBUILD CACHE Catalina 10.15.2 (19C57) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: INSTALL LATEST CLOVER / UPDATE KEXTS PRIOR TO UPDATE REPAIR PERMISSIONS AND REBUILD CACHE Catalina 10.15.3 (19D76) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: INSTALL LATEST CLOVER / UPDATE KEXTS PRIOR TO UPDATE REPAIR PERMISSIONS AND REBUILD CACHE Catalina 10.15.4 (19E266) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: INSTALL LATEST CLOVER / UPDATE KEXTS PRIOR TO UPDATE REPAIR PERMISSIONS AND REBUILD CACHE Catalina 10.15.5 (19F96) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: INSTALL LATEST CLOVER / UPDATE KEXTS PRIOR TO UPDATE REPAIR PERMISSIONS AND REBUILD CACHE Catalina 10.15.6 (19G73) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: INSTALL LATEST CLOVER / UPDATE KEXTS PRIOR TO UPDATE REPAIR PERMISSIONS AND REBUILD CACHE
  4. 4 points
    Specifications: BIOS Version: 1.16 (Latest) (needs SATA in AHCI mode, not Intel Optane or disk won't be seen) Intel 8th gen i5 8265U, 1.6GHz CPU Integrated Intel UHD620 15" 1366x768 HD non-touch LCD 16 DDR4-2400 RAM M.2 2280 256GB SATA SSD (in Key M slot) RTL8111 Gigabit Ethernet Realtek ALC255 WiFi Card - Originally came with a Qualcomm Atheros QCA9377A-5, but this model it's not supported by macOS, so it was replaced by a Lenovo Foxconn T77H649 card (Key A/E, size 2230) 802.11ac combo wireless card + Bluetooth 4.1 - BLUETOOTH NOT WORKING, ANTENNA CONNECTOR BROKEN, or it's a damaged card. Integrated HD User Facing Chicony Electronics, webcam (USB internal) Integrated Realtek Card Reader RTL8411B (PCI ven id 0x10ec, dev id 0x5287) 1 x 3.5mm universal jack (combo audio) 1 x USB 3.1 gen1 port Type-A (with PowerShare) 1x USB Type C port 3.1 2x USB 2.0 ports 1 x HDMI port Working: All the components!! UPDATE: The kext for the Card Reader it's attached separadely, I'm using Cholonam's revised kext, derived from Sinetek's initial work To use this kext, put it on Library/Extensions and rebuild the cache! Not working: Only the broken Bluetooth... PS: Guys if you know any method to fix this card, to get my BT working I'm all ears! Methods used: To install macOS: Hackintosh Guide - Install MacOS with Olarila Image, Step by Step, Install and Post Install, Windows or Mac To activate my WiFi: Broadcom BCM4350 cards under High Sierra/Mojave/Catalina Full DSDT patches: DSDT patch requests Screenshots: Credits: @Hervé he gave me the WiFi card (T77H649) and helped me to active it. @MaLd0n he as always helpd me with the DSDT and keep my Hack stable as a real Mac! And I'm thank all the community to get this machice working, the Clover guys, @headkaze with his awesome Hackintool app also. Your hard work guys, will be always appreciate by me. EDIT: Also Sinetek & Cholonam for the Card reader kext. Sinetek-rtsx 0x528710EC.zip My Clover Folder with Full DSDT patched: CLOVER - v5112 with Full DSDT.zip
  5. 4 points
    I was contacted by member @plastikman about a potential universal fix for the troublesome DW1820a cards. Hugotai posted again at Voldemort's place early december 2019 about a property injection that apparently fixed the stability issues encountered with so many DW1820a on so many laptops. Said property is pci-aspm-default and the value to inject is 0. Hugotai gave no explanation or description whatsoever so I cannot say whether the solution comes from him directly or not. A quick search on the Net revealed to me that ASPM means Active-State Power Management and relates to PCIe devices. Basically it's a protocol that offers dynamic power management through different possible states ranging from idle to powersave or performance. I also understand there is a default state which usually means power is controlled by BIOS, not the OS/kernel. This is totally unknown territory until I read more about it but setting ASPM default state to 0 probably means ASPM is disabled. On reading a little further, I came across writings that mentioned potential conflicts between idle timers or that ASPM compliance varied by device. So, the troubles experienced by so many people may indeed come from that. Anyway, I tried the property injection posted by Hugotai on the other 2 x DW1820a/BCM4350 cards I still possess and that did not properly work in my Latitude 7490: the 096JNT model (subsystem 1028:0021) and the T77H649 (subsystem 17aa:075a). Results were as follows: 096JNT: Without injection of ASPM property CPU load up to the roof after a few minutes, system freeze as expected and experienced before. IOReg reveals pci-aspm-default parameter natively set to 0x102 under the wireless card's ACPI device. With injection of ASPM defaut set to 0 All Ok, was able to use the laptop without any issue, performance degradation of wifi problems for well over 1hr. IOReg confirms pci-aspm-default parameter set to 0 under the wireless card's ACPI device. T77H649: Without injection of ASPM property CPU load up to the roof after a few minutes, system freeze as expected and experienced before. IOReg reveals pci-aspm-default parameter natively set to 0x102 under the wireless card's ACPI device. With injection of ASPM defaut set to 0 All Ok, was able to use the laptop without any issue, performance degradation of wifi problems for well over 1hr. IOReg confirms pci-aspm-default parameter set to 0 under the wireless card's ACPI device. I remind everyone that all I use is the Clover property injection detailed in post #2, in order to declare compatibility with Broadcom chips 14e4:4331 or 14e4:4353; no AirportBrcmFixup plugin kext, no bcrmfx-driver boot argument and no pin masking. So, it would seem we now have a definitive solution for DW1820A/BCM4350-based cards. I've updated the above posts to reflect on the good news. All credits to Hugotai and/or whoever identified this as a fix.
  6. 3 points
    Dell Optiplex 3070 Micro Form Factor 100% working EFI. Dell Optiplex 3070 Micro 100 Percent Working.zip Thanks Jake for the support.
  7. 3 points
    Hello Elan PS/2 touchpad users! SmartTouchpad kext was decent until Voodoo came with Magic Touchpad integration. Since then our friends with Synaptics PS/2 and I2C touchpads had much better support for their touchpads. Therefore, I have ported Elan support from Linux kernel into VoodooPS2 so that now Elan PS/2 touchpad can also emulate magic touchpad and it means it can support all native macOS gestures, including tools like BetterTouchTool! Why this is not included in VoodooPS2? Because the kext has to be tested first. It works well for me (asus laptop), but I would like to hear feedback from more users, from more devices. Both if it works and if it doesn't. Once it is confirmed the kext works well, it might be merged into VoodooPS2 main project. What should work? Actually, everything. Basic touch, two finger scroll, multitouch, three and more fingers gestures, apple touchpad settings panel - everything. How to install: Just like normal VoodooPS2 controller - just copy the kext to Clover/OC (and add appropriate entries to OC config in case you use OpenCore). If you already have VoodooPS2 controller - just replace the file with this release. Download: https://github.com/BAndysc/VoodooPS2/releases Special thanks to: Kishor Prins and whole Voodoo Input team Please leave feedback even if it works, it will help me to merge it into official Voodoo PS2.
  8. 3 points
    Last update: 16 Sep 2020 Here are BIOS settings that are known to work on the 7490 (8th gen. Kaby Lake R CPU with Intel UHD620 graphics) under Mojave and Catalina. These settings were tested and verified with BIOS 1.8.0 / 1.9.3 / 1.10.0 / 1.11.0 / 1.12.2 / 1.13.1 / 1.14.0 / 1.15.1 / 1.16.0. General . Boot Sequence: * Boot List Option = UEFI (-> Boot Sequence list will be set accordingly) . Adanced Boot Options: * Enable Legacy Option ROMs = On (required to boot legacy external devices such as USB media or SD cards) * Enable Attempt Legacy Boot = On . UEFI Boot Path Security: * Never (or whatever other value) System Configuration . Integrated NIC = Enabled . SATA Operation = AHCI . Drives: * SATA-2 = On * M.2 PCIe SSD-0 = On . SMART Reporting: * Enable SMART Reporting = On or Off . USB Configuration: * Enable USB Boot Support = On * Enable External USB Port = On . Dell Type-C Dock Configuration: * Always Allow Dell Docks = On . USB PowerShare: * Enable USB PowerShare = On . Audio: * Enable Audio = On * Enable Microphone = On * Enable Internal Speaker = On . Keyboard illumination: * Bright = On (or any desired value) . Keyboard Backlight on AC: * Any desired setting . Keyboard Backlight on Battery: * Any desired setting . Unobtrusive Mode: * Enable Unobtrusive Mode = Off . Miscellaneous Devices: * Enable Camera = On * Secure Digital (SD) Card Boot = On * Enable Secure Digital (SD) Card = On * Secure Digital (SD) Card Read-Only Mode = Off Video . LCD Brightness = Whatever settings you prefer Security . Admin Password = not set (or whatever) . System Password = not set (or whatever) . Internal HDD-0 PW | M.2 SATA SSD-2 Password = not set (or whatever) . Strong Password = Off . Password Configuration = default settings . Password Bypass = Disabled . Password Change: Allow Non-admin Password Changes = on . Non-Admin Setup Changes = Off . UEFI Capsule Firmware Updates = On . TPM 2.0 Security = Off or On with whatever desired settings . Absolute(R) = Disabled (or whatever desired settings) . OROM Keyboard Access = Enabled . Admin Setup Lockout = Off . Master Setup Lockout = Off . SMM Security Mitigator = Off Secure Boot . Secure Boot Enable = Disabled . Secure Boot Mode = Deployed Mode . Expert Key Management: * Enable Custom Mode = Off * Custom Mode Key Management = PK Intel Software Guard Extensions . Intel SGX Enable = Software Controlled . Enclave Memory Size = not configurable Performance . Multi Core Support = All . Intel SpeedStep = Enabled . C-States control = On . Intel TurboBoost = Enabled . HyperThread Control = Enabled Power Management: . AC Behavior: * Wake on AC = Off . Enable Intel Speed Shift Technology = On . Auto On Time = Disabled . USB Wake Support * Enable USB Wake Support = On or Off * Wake on Dell USB-c Dock = On or Off . Wireless Radio Control: * Control WLAN radio = Off * Control WWAN radio = Off . Wake on LAN/WLAN = Disabled . Block Sleep = Off . Peak Shift = Off . Advanced Battery Charge Configuration = Off . Primary Battery Charge Configuration = Express Charge (or any other choice) . Type-C Connector Power = 7.5 or 15 Watts POST Behavior . Adapter Warnings = Enabled . USB-C Warnings = Enabled (item only available in later BIOS versions) . Keypad (Embedded) = Fn Key Only . Numlock Enable = Enabled . Fn Lock Optio: * Fn Lock = On * Lock Mode Disable/Standard = On . Fast Boot = Minimal . Extend BIOS POST Time = 0 seconds (or any other choice) . Full Screen Logo = On or Off . Warnings and Errors = Prompt on Warnings and Errors. MAC address Pass-Through = Passthrough MAC address Manageability . Intel AMT Capability = Enabled (item only available in later BIOS versions) . USB Provision = Off . MEBx Hotkey = Enabled Virtualization Support . Virtualization = Enabled . VT for Direct I/O = Disabled . Trusted Execution = Off Wireless . Wireless Switch: * WWAN = On * WLAN = On * GPS (on WWAN Module) = On * Bluetooth = On . Wireless Device Enable: * WWAN/GPS = On * Bluetooth = On * WLAN = On
  9. 3 points
    @ten2pwr6 Can you try adding this SSDT to the patched folder and see if it fixed the issue. Worked for @acquarius.13 's 450 G5 SSDT-AWAC.aml.zip
  10. 3 points
    While the EM7430 works with my kext. (I guess the product ID needs to be adjusted still). The EM7455 seems not. What I did: Wrote the kext for DW5811e / EM7411 according to the correct PID & VID attached above. Which after it appears on WANN section (location id show xxxxxxxx / 0 as others also have in their screen). Then with the correct APN the error shows: So I updated the firmware and all config settings using LIVE UBUNTU CD 18.04 with: https://github.com/danielewood/sierra-wireless-modems His autoscript is perfect for updating FW, configuring the whole card according to our needs & sets the PID/VID to generic to bypass any vendor locks. Whilst I updated the kext to reflect all MC/EM7455 cards PID/VID (Lenovo / DELL / Generic). Still the error "Network Connection ... " shows. Please also see the location difference: NOTE the firmware: SWI9X30C_02.08.02.00 r5428 CARMD-EV-FRMWR2 2016/01/06 20:38:53 While at!priid? shows the updated firmware: SWI9X30C_02.33.03.00_00_00_GENRIC So I manually check the connection using COM port: screen /dev/tty.wwan 115200 screen /dev/tty.wwan 115200 Which after I'm able to manually connect using at commands. Any ideas where to look? Perhaps it is the interface mapping? <key>InterfaceMapping</key> <dict> <key>0</key> <dict> <key>name</key> <string>wwanDM</string> </dict> <key>2</key> <dict> <key>name</key> <string>wwanGPS</string> </dict> <key>3</key> <dict> <key>name</key> <string>wwan</string> </dict> </dict>
  11. 3 points
    Kind donations contribute to the running costs of OSXLatitude.com: server hosting, high-speed Internet line, forum licences, etc. Thank you.
  12. 3 points
    Hey, Max. I Found a good solution to fix the slash/? key on pt_bt layouts of lenovo thinkpad. Background information: Followin the apple tn2450 table i found the key code 0x87 https://developer.apple.com/library/archive/technotes/tn2450/_index.html Now, i follow the apple usb 2 adb table and fount 5e correspondent adb code to 0x87 from hid_adb_2_usb_keymap https://opensource.apple.com/source/IOHIDFamily/IOHIDFamily-606.1.7/IOHIDFamily/Cosmo_USB2ADB.c to check keyboard events, use ioio -s ApplePS2Keyboard LogScanCodes 1 it to trigger the logging of the adb codes and look at console filtering by "ApplePS2Keyboard" Finally, the simplified solution: Add a custom map in VoodooPS2Controller.kext/Contents/PlugIns/VoodooPS2Keyboard.kext/Contents/Info.plist The remap: e01d=5e Using PlistBuddy (i have a automated script to build my efi folder) plist=VoodooPS2Controller.kext/Contents/PlugIns/VoodooPS2Keyboard.kext/Contents/Info.plist node=':IOKitPersonalities:ApplePS2Keyboard:Platform\ Profile:Default:Custom\ ADB\ Map' /usr/libexec/PlistBuddy -c "Add ${node}:1 string 'e01d=5e'" $plist manually: open VoodooPS2Controller.kext/Contents/PlugIns/VoodooPS2Keyboard.kext/Contents/Info.plist find IOKitPersonalities -> ApplePS2Keyboard -> Platform Profile -> Default -> Custom ADB Map and add a line <string>e01d=5e</string> results like: <key>Default</key> <dict> <key>Breakless PS2</key> <array> <string>;Items must be strings in the form of breaklessscan (in hex)</string> </array> <key>Custom ADB Map</key> <array> <string>;Items must be strings in the form of scanfrom=adbto (in hex)</string> <string>e01d=5e</string> </array> <key>Custom PS2 Map</key> <array>
  13. 3 points
    Hello all! Here my configuration. Maybe someone will need it. Dell Latitude e7440 (no Fingerprint version) CPU: Haswell Intel Core i7-4600u dual core 4th gen IGPU: Intel Graphics HD 4400 Ram: 16GB DDR3 SSD M-SATA: 256GB Bios: A28 Mac Os: Catalina 10.15.4 Working: full graphics acceleration on Intel HD4400 iGPU, including brightness control (Fn+F3 Brightness up Fn+↓ Brightness up) (with Lilu v1.4.2 + Whatevergreen v1.3.7) multi-display with HDMI audio, including HDMI, (no microphone input) and headset output (with AppleALC v1.4.7 & No Inject audio) GigEthernet LAN connection (with IntelMausiEthernet 2.5.0 kext) wireless and bluetooth with any compatible card (a BCM94352HMB with Airportbrcmfixup.kext v2.0.6, BrcmBluetoothInjector.kext 2.5.1, BrcmFirmwareData.kext 2.2.10, BrcmFirmwareRepo.kext 2.5.1, BrcmPatchRAM3.kext 2.5.1, FakePCIID_Broadcom_WiFi.kext 1.3.15, FakePCIID.kext 1.3.15) All USB ports (3.0) integrated webcam sleep & wake battery management (with ACPIBatteryManager v1.90.1) keyboard and touchpad, max 2 finger multitouch(with VoodooPS2ControllerR6 v6.0.0) SD Card reader Not working: Nothing For Bios settings follow this perfect guide by Hervè (set like this all option that you can find) For create bootable usb/Installation/Post Installation follow this perfect guide by Hervè (just download latest Catalina 10.15.4 from Apple Store) Is better to use the latest clover release, for download it click here You can also follow these steps, starting from the installation of the clover in the usb stick (after the media creation tool process in terminal is done) : Run Clover r51xx.pkg and select USB (Install Mac Os Catalina) as destination Just flag in true on Clover for UEFI booting only, Install Clover in the ESP, UEFI Drivers - Racommended drivers - Install Open terminal and paste: diskutil list Choose your usb EFI partition and type (for example disk1s2): sudo diskutil mount disk1s2 Open Finder and open mounted EFI Replace the EFI folder with this: EFI 10.15.4 e7440 V2.zip Boot from USB and install Mac OS For post-installation repeat the same steps with these differences: Run Clover r51xx.pkg and select your SSD/HHD as destination Just flag in true on Clover for UEFI booting only, Install Clover in the ESP, UEFI Drivers - Recommended drivers - Install Remove all usb sticks and others disk (leave only the target Mac Os disk) and just type : sudo diskutil mount EFI Open Finder and open mounted EFI Replace the EFI folder with the USB EFI Change your serial number in clover configurator SMBIOS section Enjoy your hack! Clover Configurator.app.zip
  14. 3 points
    A few things are required to successfully run macOS Catalina on a Hackintosh, whether through a new/fresh installation of a direct upgrade from a previous OS X/macOS version/release. 1/ Embedded Controller: As mentioned here by @MaLd0n at InsanelyMac, since beta #5, macOS Catalina requires Embedded Controller (EC)-related patching for many computers. It's therefore important to check your Embedded Controller device (aka "PNP0C09" id) in DSDT/ACPI and apply the mandatory device renaming to "EC" in Clover's config (or directly in DSDT), failing what, Catalina will never boot. For instance, most Dell laptops since the era of the Latitude E4x00/E5x00/E6x00 range have an Embedded Controller device called "ECDV" in DSDT; in Clover, the necessary ACPI device renaming is as follows: Description: Changes ECDV to EC Find: 45434456 (ASCII for "ECDV" in hexadecimal notation) Replace: 45435F5F (ASCII for "EC__" in hexadecimal notation) Other known names for the Embedded Controller include "H_EC" or "EC0". If you find no Embedded Controller device in ACPI, this patch is not necessary. 2/ Clover: Clover needs to be at a minimum version supporting Catalina. Versions r503x, r504x and r505x are generally Ok. At the date of general release of Catalina, we recommend using Clover r5093 as the minimum version. Clover versions are available off Dids' Github repo. 3/ Add-on kexts: Lilu and associated plugins also need to be at versions updated for Catalina. At time of writing, we recommend the following minimum versions, all available off Acidanthera's Github repos: Lilu v1.3.8 Whatevergreen v1.3.3 AppleALC v1.4.2
  15. 3 points
    With Catalina 10.15, Apple went further into increasing the security of its OS and the system's/root partition is now locked upon system startup. One of the consequences is that, by default, /System/Library/Extensions folder (/S/L/E) is locked and can not be modified in any way. In the same respect, other reserved folders such as /usr/bin or /usr/sbin are locked too. This can be a problem for such situations where a vanilla kext has to be replaced in /S/L/E or a file of /S/L/CoreServices has to be patched. The trick is basically to mount Catalina's root partition in Read-Write (RW) mode instead of Read-Only (RO) mode. This can be accomplished through Terminal with the following command: sudo mount -uw / followed a restart of the Finder through Terminal command: sudo killall Finder or simply by relaunching the Finder from the Apple menu:
  16. 3 points
    Hi all, have been playing around with the driver to see if I can get firmware upload in Mojave to work on my dw1820a without needing windows to upload the firmware. It seems to be working ok , but am still testing to see if it works consistently. Attaching the kexts if anyone else would like to try with their dw1820a. These need to be uploaded to /EFI/CLOVER/Kexts/Other. Make sure you don't have any equivalent kexts in /L/E or /S/L/E. Let me know if you have any success. BrcmBluetoothInjector.kext.zip BrcmFirmwareData.kext.zip BrcmPatchRAM2.kext.zip
  17. 3 points
    In case the above Google link becomes unavailable... Dell_Precision-M6800_Jul2019.zip
  18. 3 points
    Last update: 28 Jan 2020 Dell DW1820A: Ok Ok Ok DW1820A is a pretty good combo card providing 2.4/5GHz 802.11ac wireless at 867Mbps + Bluetooth 4.1. As stated at Wikidevi, there appears to be a few different models of the card. Whilst they all carry the same Broadcom id 14e4:43a3, they each carry a different subsystem id/part #: 1028:0021 (part # CN-0VW3T3) -> 100% Ok with ASPM disabled (originally tested 100% Ok on my Latitude 7490 without ASPM tuning) 1028:0021 (part # CN-096JNT) -> 100% Ok with APSM disabled 1028:0022 (part # CN-096JNT) -> 100% Ok with APSM disabled 1028:0023 (part # CN-0VW3T3) -> 100% Ok with APSM disabled 1028:0023 (part # CN-08PKF4) -> 100% Ok with APSM disabled I acquired a Dell DW1820A a few months ago and was able to play with that card on a Latitude 7490 laptop (fitted with an M.2 2230 Key A+E WLAN slot) that I targeted for Mojave. The model I received was CN-0VW3T3. Before it was later established that not all DW1820A were equal, I purchased a 2nd one and, as it turned out to be, was lucky to receive another 0VW3T3 model. /!\ The 1st thing I want to report is that I encountered difficulties booting my Mojave USB installer and installing macOS with the card plugged in. I had to disable wireless in BIOS to be able to install Mojave. Once it was installed, booting Mojave with wireless enabled in BIOS would cause quite severe lag and performance degradation once at the desktop, as if the card just clogged up CPU ressources. This was because I had not applied any particular tuning for the card and, of course, this was resolved once I implemented the necessary fix detailed below. /!\ Searching through the Web for that DW1820A/BCM4350, I came accross a few forum posts/threads that mentionned: rolling back the Yosemite IO80211Family kext to get the card to work, although with instability and regular KPs removing AirPortBrcmNIC plugin kext from IO80211Family kext, patching AirPortBrcm4360 plugin kext with the id of the DW1820A and installing AirportBrcmFixup kext with a couple of parameters (Credits to Hugotai, cf. his post @Voldemort's place, 2nd Dec 2018) Whilst I did not really contemplate doing the 1st thing, I did envisage the 2nd one and started to look at the differences between Yosemite's version of IO80211Family kext and Mojave's. The main difference I had already noticed was that device id 14e4:43a3 was handled by AirPortBrcm4360 up to Sierra 10.12 and by AirPortBrcmNIC since High Sierra 10.13. Further reading and experimenting showed me that AirPortBrcmNIC kext was the root cause of the problem. Building on Hugotai's success, I seeked to work out an easier solution to bypassing AirPortBrcmNIC kext that would not require kext removal and Info.plist patching but, instead, something that could be implemented through hardware properties injection, either through DSDT patching or Clover configuration. Once Hugotai's solution was verified and confirmed, I worked out the following Clover-based solution for HighSierra/Mojave: identify the IOReg/ACPI device to which the DW1820A card is attached (use IORegistryExplorer app to that effect). Eg: [email protected],yy->[email protected] in the absence of individual ACPI device entry under the PCI bridge for the card, select "FixAirport" ACPI Fix in Clover. That'll create a device "ARPT" @0 under the bridge and that's what you'll inject properties to. This may also require to select "AddDTGP" ACPI Clover fix if your DSDT does not possess any DTGP method. Use Clover Configurator app to that effect. inject the following properties either in DSDT or through Clover (latter recommended): compatibility of the card with Broadcom chips 14e4:4353 or 14e4:4331 that are handled by IO80211Family's PlugIn kext AirPortBrcm4360 ASPM disabling (required for most cards to avoid CPU clogging and system freeze) optionally, add SysProfiler's cosmetic info such as PCIe Slot, card's make and model, etc. and that's it ! Nothing to do to IO80211Family kext or its PlugIns which all remain untouched/unmodified/full vanilla in /S/L/E. It really could not be simpler... NB: if your card's country code absolutely requires to be changed, say for full 5GHz/80MHz operations, add the following steps: install AirportBrcmFixup kext in /L/E + repair permissions + rebuild your cache or inject it through Clover's EFI/CLOVER/kexts/Other add boot argument brcmfx-country=XX (where XX is the target value, eg: US, FR, #a, etc.) to the Boot section of your Clover config but, beware, I found that using AirportBrcmFixup (v1.1.9 at time of writing) with country code other than default's US setting of the card impacted my wireless performance (fluctuating and reduced RX/TX rate). For instance, with country code set to FR (for France), I would not connect at 80MHz on my 5GHz Wireless network, only to 40MHz which resulted in a local wireless connection limited to 400Mbps (vs. 867Mbps) and reduced my overall Internet RX rate by about 60% and TX rate by about 10%: with country code set to #a (to get full 80MHz connection), I could not obtain DFS channel mode to my local router and I noticed fluctuating/unstable RX/TX rates: without AirportBrmfixup, my wireless connection runs solid at 867Mbps and SpeedTest returns a solid TX and RX rates at 300Mbps (i.e. the maximum speed of my Internet connection). Properties injection through DSDT: On my laptop, the DW1820A was found attached to device RP03.PXSX located at IO address 0x001C0002, i.e. 1C,2. The DSDT patch required to inject properties could look like this (devices names will differ from one computer to another of course!): Device (RP03) // PCIe Root Bridge { name (_ADR, 0x001C0002) [...] [...] [...] Device (PXSX) // DW1820A card attached to this device (FixAirport fix required if such device is missing) { Name (_ADR, Zero) [...] [...] [...] Method (_DSM, 4, NotSerialized) // _DSM: Device-Specific Method { If (LEqual (Arg2, Zero)) { Return (Buffer (One) { 0x03 }) } Return (Package () { "AAPL,slot-name", // Optional Buffer () { "WLAN" }, "device_type", // Optional Buffer () { "Airport Extreme" }, "name", // Optional Buffer () { "Airport" }, "model", // Optional Buffer () { "Dell DW1820A 802.11ac wireless" }, "compatible", // Mandatory Buffer () { "pci14e4,4353" // Declares compatibility with BCM43224; "pci14e4:4331" for BCM94331 may also be used }, "pci-aspm-default", // Mandatory for most cards Buffer (One) { 0x00 // Disables ASPM for PCIe device } }) } } } Properties injection through Clover config: An easier alternative is to inject those properties in Clover via Clover Configurator app. This can be done within the Devices section by injecting the desired properties in the Properties sub-section: In the left part, add the PCIe address of the targeted device in the form PciRoot(0x0)/Pci(<root device address>)/Pci(<actual device address>) In the right part, add the above properties in single lines and with the right types (String, Data, Number) For instance, in the case of my laptop, the target device will be PciRoot (0x0)/Pci(0x1C,0x02)/Pci(0x0,0x0) for [email protected]>[email protected],2->[email protected] Then, properties will be injected as lines of keys of 3 x possible types: strings, hex data blocks or numbers. For instance, to declare compatibility with 14e4:4353, the line will consist of Property Key set to compatible, Key Value set to pci14e4,4353 and Key Type set to STRING. The complete properties injection will be: Device = PciRoot(0x0)/Pci(0x1c,0x02)/Pci(0x0,0x0) Key = compatible | Value = pci14e4,4353 | Type = STRING Key = pci-aspm-default | Value = 0 | Type = NUMBER Key = AAPL,slot-name | Value = WLAN | Type = STRING (optional) Key = device_type | Value = Airport Extreme | Type = STRING (optional) Key = name | Value = Airport | Type = STRING (optional) Key = model | Value = Dell DW1820 (BCM4350) 802.11ac wireless | Type = STRING (optional) Once the device properties are injected in Clover or DSDT, there's nothing left to do but reboot the computer. The DW1820A card will then be fully active and capable to connect to 2.4/5GHz networks at full speed. Results: On the Bluetooth side, once the usual Rehabman's Broadcom firmware patching kexts are installed (BrcmFirmwareRepo + BrcmPatchRAM2), the BT4.1 module will be fully operational and capable of supporting AirDrop and Handoff! Links: Clover Configurator app Rehabman's Broadcom Firmware patching kexts Acidanthera AirportBrcmFixup kext - - - - - - - - - - Edit: 06 Jan 2020 Updated with freshly found ASPM disabling property injection that fixes all outstanding stability issues. DW1820A #096JNT and Foxconn T77H649 now tested 100% Ok. DW1820A #08PKF4 should be just the same. - - - - - - - - - - Edit: 28 Jan 2020 Finally got to test a DW1820A #08PKF4 and it's also 100% Ok with ASPM disabled.
  19. 2 points
    Built an Hackintosh Recently with the following Specs: Atermiter X79G motherboard 45$ Xeon E5-2650V2 ~50$ 64GB DDR3 ECC RAM Nvidia GT 710 graphic card: sanddisk 500GB SSD You can directly install Mojave without modifying anything in the bios... using this EFI.. But if you have to install/upgrade to Catalina 10.15.2, before installing or upgrading Disable Virtualization support - CPU configuration disable VTX-D - North bridge. Disable USB ECHI support Post installation you can enable them again. Had no issues with virtualization performance etc... Boots in less than 10 seconds. All working - except small static in AUDIO... (hardly noticeable, but goes away once you play something)... EFI_desktop.zip
  20. 2 points
    Success: HP840 G3 with DW1830 Works: Sleep / Wake SD card reader Internal speaker / Headphone Keyboard / Touchpad Ethernet / Wifi (replaced with DW1830) DP video / Audio USB 3.0 Ports Multi touch gestures VGA (not tested, don't care for it)
  21. 2 points
    Last update: 16 Sep 2020 Specifications: BIOS v1.8.0 v1.9.3 v1.10.0 v1.11.0 v1.12.2 v1.13.1 v1.14.0 v1.15.1 v1.16.0 (needs SATA in AHCI mode, not RAID or disk won't be seen) Intel 8th gen Kaby Lake R quad-core i7-8650U 1.9GHz CPU (Turbo boost up to 3.9GHz for 3 & 4 cores and up 4.2GHz for 1 & 2 cores) integrated Intel UHD620 GPU 300-1150MHz (PCI ven id 0x8086, dev id 0x5917) 14" 1920x1080 FHD non-touch LCD 16Go DDR4-2400 RAM M.2 2280 512GB SATA SSD (in Key M slot) Intel i219-LM Gigabit Ethernet (PCI ven id 0x8086, dev id 0x15d7) Realtek ALC256 (ALC3246) High Def audio (PCI ven id 0x10ec, dev id 0x0256) Dell DW1820A M.2 802.11ac combo wireless card (PCI ven id 0x14e4, dev id 0x43a3) + Bluetooth 4.1 (PCI ven id 0x0a5c, dev id 0x6412) integrated Realtek HD webcam (USB internal, PCI ven id 0x0bda, dev id 0x5650) integrated Realtek RTS525A microSD 4.0 card reader (PCI ven id 0x10ec, dev id 0x525a) Alps I2C HID Multi-Touch Touchpad (PCI ven id 0x1028, dev id 0x081c) Alps I2C HID TrackPoint (PCI ven id 0x044e: dev id 0x1212) 1 x M.2 2230 WLAN slot (Key A for Key A/E cards) 1 x M.2 2242 WWAN slot (Key B for Key B & Key M/B cards) 1 x 3.5mm universal jack (combo audio) 3 x USB 3.1 gen1 ports Type-A (right port with PowerShare) 1 x HDMI 1.4 port 1 x DisplayPort on USB Type-c Lat7490:~ admin$ lspci -nn 00:00.0 Host bridge [0600]: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers [8086:5914] (rev 08) 00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 [8086:5917] (rev 07) 00:04.0 Signal processing controller [1180]: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem [8086:1903] (rev 08) 00:14.0 USB controller [0c03]: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller [8086:9d2f] (rev 21) 00:14.2 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Thermal subsystem [8086:9d31] (rev 21) 00:15.0 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 [8086:9d60] (rev 21) 00:15.1 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #1 [8086:9d61] (rev 21) 00:15.2 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #2 [8086:9d62] (rev 21) 00:15.3 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #3 [8086:9d63] (rev 21) 00:16.0 Communication controller [0780]: Intel Corporation Sunrise Point-LP CSME HECI #1 [8086:9d3a] (rev 21) 00:16.3 Serial controller [0700]: Intel Corporation Sunrise Point-LP Active Management Technology - SOL [8086:9d3d] (rev 21) 00:17.0 SATA controller [0106]: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] [8086:9d03] (rev 21) 00:1c.0 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #1 [8086:9d10] (rev f1) 00:1c.2 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #3 [8086:9d12] (rev f1) 00:1f.0 ISA bridge [0601]: Intel Corporation Sunrise Point LPC Controller/eSPI Controller [8086:9d4e] (rev 21) 00:1f.2 Memory controller [0580]: Intel Corporation Sunrise Point-LP PMC [8086:9d21] (rev 21) 00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21) 00:1f.4 SMBus [0c05]: Intel Corporation Sunrise Point-LP SMBus [8086:9d23] (rev 21) 00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (4) I219-LM [8086:15d7] (rev 21) 01:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader [10ec:525a] (rev 01) 02:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4350 802.11ac Wireless Network Adapter [14e4:43a3] (rev 08) For recommended BIOS settings, see here. NB: The E7490 is able to boot from microSD card.
  22. 2 points
    Last update: 14 Sep 2020 This 2nd inventory comes to complement our original one created back in 2013 which is now restricted to cover wireless cards under Snow Leopard 10.6 to El Capitan 10.11. This new list will provide the equivalent for macOS versions (Sierra 10.12 and later) given that it's getting complicated to keep everything under a single text table and Apple has been increasingly dropping support for some cards since the introduction of macOS Sierra in 2016. I invite everyone to bring his/her own contribution and it'll be added to the list. This post will be updated as contributions come along in order to keep the list under control. Hardware specifications can be verified here: https://wikidevi.wi-cat.ru. Note: OOB = Out of the Box /!\ Sierra 10.12 dropped support for old Broadcom BCM431x and BCM4321 cards. There is no workaround, they have to be replaced. /!\ /!\ Mojave 10.14 dropped support for Atheros cards. The workaround is to install the Atheros40 kext from an earlier release like High Sierra 10.13.6, i.e. copy to /L/E + repair permissions + rebuild cache. /!\ 10.13.6_AirPortAtheros40.kext.zip /!\ Catalina 10.15 dropped support for BCM4322 (14e4:432b). AirPortBrcm4331 plugin kext of IO80211Family kext was abandoned. This affects cards such as DW1510. Workaround is to simply install Mojave's (or High Sierra's) IO80211Family kext, i.e. copy to /L/E + repair permissions + rebuild cache (leaving /S/L/E untouched) or, if that does not work, replace Catalina's IO80211Family kext in /S/L/E by Mojave's (or High Sierra's) but this will need to be done again after each update because vanilla kexts will be re-instated. /!\ 10.14.6_IO80211Family.kext.zip /!\ Support for BCM4352 (14e4:43b1) was reported dropped in Catalina. This would affect cards such as DW1550, AW-CE123H or DW1560. Same workaround as detailed above for BCM4322 was reported necessary (+ previously required patch/property injection of course). However, clarification is required because this reported drop of support was contradicted by people who said BCM4352 cards worked OOB and behaviour/fixes appeared inconsistent throughout the Catalina builds... /!\ Catalina 10.15 no longer supports injection or caching of High Sierra's AirPortAtheros40 kext. Instead, install High Sierra's IO80211Family kext, i.e. copy to /L/E + repair permissions + rebuild cache (leaving /S/L/E untouched) or, if that does not work, replace Catalina's IO80211Family kext in /S/L/E by High Sierra's. /!\ 10.13.6_IO80211Family.kext.zip Unsupported: Vendor Model Format Ven-Dev Chip Rate Si HS Mj Ca OOB Kext (driver) Atheros AR5BXB6 Mini PCIe 168c-001c AR5424 A/B/G N N N N - - AzureWave AW-CB161H ½Min PCIe 10ec-8821 RTL8821AE A/B/G/N/AC N N N N - - AzureWave AW-CB209NF NGFF/M.2 10ec-8821 RTL8821AE A/B/G/N/AC N N N N - - AzureWave AW-CB210NF NGFF/M.2 14e4-43ec BCM4356 A/B/G/N/AC N N N N - - AzureWave AW-NB155NF NGFF/M.2 14e4-4365 BCM43142 B/G/N N N N N - - Dell DW1390 Mini PCIe 14e4-4311 BCM4311 B/G N N N N - - Dell DW1395 Mini PCIe 14e4-4315 BCM4312 B/G N N N N - - Dell DW1490 Mini PCIe 14e4-4312 BCM4311 A/B/G N N N N - - Dell DW1505 Mini PCIe 14e4-4328 BCM4321 A/B/G/N N N N N - - Dell DW1397 ½Min PCIe 14e4-4315 BCM4312 B/G N N N N - (=DW1395) Dell DW1501 ½Min PCIe 14e4-4727 BCM4313 A/B/G/N N N N N - - Dell DW1503 ½Min PCIe 14e4-4727 BCM4313 A/B/G/N N N N N - - Dell DW1504 ½Min PCIe 14e4-4727 BCM4313 B/G/N N N N N - - Dell DW1530 ½Min PCIe 14e4-4359 BCM43228 A/B/G/N N N N N - - Dell DW1540 ½Min PCIe 14e4-4359 BCM43228 A/B/G/N N N N N - - Dell DW1701 ½Min PCIe 14e4-4727 BCM4313 B/G/N N N N N - - Dell DW1704 ½Min PCIe 14e4-4365 BCM43142 B/G/N N N N N - - Dell DW1810 NGFF/M.2 168c:0042 QCA9377 A/B/G/N/AC N N N N - (=QCNFA435) Dell DW1820 NGFF/M.2 168c:003e QCA6174A A/B/G/N/AC N N N N - (=QCNFA344A) Intel All - - - - N N N N - No exception! Qualcomm QCNFA435 NGFF/M.2 168c-0042 QCA9377 A/B/G/N/AC N N N N - - Qualcomm QCNFA344A NGFF/M.2 168c-003e QCA6174A A/B/G/N/AC N N N N - - Ralink RT5390 ½Min PCIe 1814-539b RT5390 B/G/N N N N N - - Supported: Vendor Model Format Ven-Dev Chip Rate Si HS Mj Ca OOB Kext (driver) Atheros AR5B91 Mini PCIe 168c-002a AR9281 B/G/N Y Y * * Y * See above for Mojave Atheros AR5BXB72 Mini PCIe 168c-0024 AR5418/5133 A/B/G/N Y Y * * N patch Atheros40 Atheros AR5BXB92 Mini PCIe 168c-002a AR9280 A/B/G/N Y Y * * Y - Atheros AR5BXB112 Mini PCIe 168c-0030 AR9380 A/B/G/N Y Y * * Y - Atheros AR5B22 Mini PCIe 168c-0034 AR94621 A/B/G/N Y ? * * N FW + Atheros40 patch Atheros AR5B93 ½Min PCIe 168c-002a AR9283 B/G/N Y Y * * Y - Atheros AR5B95 ½Min PCIe 168c-002b AR9285 B/G/N Y Y * * N DSDT/Atheros40 patch Atheros AR5B97 ½Min PCIe 168c-002e AR9287 B/G/N Y Y * * N DSDT/Atheros40 patch Atheros AR5B195 ½Min PCIe 168c-002b AR9285 B/G/N Y Y * * N (=AR5B95+BT3.0) Atheros AR5B197 ½Min PCIe 168c-002e AR9287 B/G/N Y Y * * N (=AR5B97+BT3.0) Atheros AR5BHB92 ½Min PCIe 168c-002a AR9280 A/B/G/N Y Y * * Y - Atheros AR5BHB112 ½Min PCIe 168c-0030 AR9380 A/B/G/N Y Y * * Y - Atheros AR5B125 ½Min PCIe 168c-0032 AR94851 B/G/N Y ? * * N FW + Atheros40 patch Atheros AR5B225 ½Min PCIe 168c-0032 AR94851 B/G/N Y ? * * N FW + Atheros40 patch AzureWave AW-NB037H ½Min PCIe 168c-002b AR9285 B/G/N Y Y * * N (=AR5B195) AzureWave AW-NB048H ½Min PCIe 168c-002b AR9285 B/G/N Y Y * * N (=AR5B195) AzureWave AW-NB290H ½Min PCIe 14e4-4357 BCM43225 B/G/N Y Y Y ? N DSDT/kext patch AzureWave AW-CE123H ½Min PCIe 14e4-43b1 BCM4352 A/B/G/N/AC Y Y Y * N DSDT/kext patch AzureWave AW-CB160H ½Min PCIe 14e4-43a0 BCM4360 A/B/G/N/AC Y Y Y Y Y - Dell DW1502 ½Min PCIe 168c-002b AR9285 B/G/N Y Y * * Y (=AR5B95) Dell DW1506 ½Min PCIe 168c-0032 AR94851 B/G/N Y ? * * N (=AR5B125) Dell DW1510 ½Min PCIe 14e4-432b BCM4322 A/B/G/N Y Y Y * Y - Dell DW1515 ½Min PCIe 168C-002a AR9280 A/B/G/N Y Y * * Y (=Atheros xB92) Dell DW15202 ½Min PCIe 14e4-4353 BCM43224 A/B/G/N Y Y Y Y Y/N MBA5,2/Brcm4360 patch Dell DW1550 ½Min PCIe 14e4-43b1 BCM4352 A/B/G/N/AC Y Y Y * N DSDT/kext patch Dell DW1601 ½Min PCIe 168c-0034 AR94621 A/B/G/N/AD Y Y ? ? N (=AR5B22) Dell DW1702 ½Min PCIe 168c-002b AR9285 B/G/N Y Y ? ? N (=AR5B195) Dell DW1703 ½Min PCIe 168c-0032 AR94851 B/G/N Y Y ? ? N (=AR5B225) Dell DW1705 ½Min PCIe 168c-0036 AR95651 B/G/N Y Y ? ? N FW + Atheros40 patch Dell DW1560 NGFF/M.2 14e4-43b1 BCM4352 A/B/G/N/AC Y Y Y * N DSDT/kext patch Dell DW1707 NGFF/M.2 168c:0036 AR95651 B/G/N Y Y ? ? N FW + Atheros40 patch Dell DW1802 NGFF/M.2 168c-0034 AR94621 A/B/G/N Y Y ? ? N (=AR5B22) Dell DW1820A3 NGFF/M.2 14e4-43a3 BCM43503 A/B/G/N/AC Y Y Y Y N DSDT patch/injection Dell DW1830 NGFF/M.2 14e4-43ba BCM43602 A/B/G/N/AC Y Y Y Y Y - Asus USB-N10 USB 2.0 0b05-1786 RTL8188SU B/G/N ? ? ? ? N RealTek's v2.0.1 Asus USB-AC51 USB 2.0 0b05-17d1 MT7610U A/B/G/N/AC ? ? ? ? N Asus's driver CSL Nano V.2 USB 2.0 0bda-8176 RTL8188CUS B/G/N ? ? ? ? N RealTek's v2.0.1 D-Link DWA-121 A1 USB 2.0 2001-3308 RTL8188CUS B/G/N ? ? ? ? N RealTek's v2.0.1 Lafalink LF-D10 Nano USB 2.0 148f-7601 MT7601 B/G/N Y Y Y Y N Ralink's v4.2.9.10/RT2870 Driver Lafalink LF-D12 Nano USB 2.0 148f-5370 RT5370 B/G/N ? ? ? ? N Ralink's v4.2.9.2 NetGear WNA3100M USB 2.0 0846-F001 RTL8192CU B/G/N ? ? ? ? N Realtek's v2.0.1 On-Nwrks N300 USB 2.0 0846-F001 RTL8192CU B/G/N ? ? ? ? N Realtek's v2.0.1 Tenda W522U USB 2.0 148f-3572 RT3572 A/B/G/N Y Y ? ? N TP-Link/Ralink TP-Link TL-WN725N v2 USB 2.0 0bda-8179 RTL8188EUS B/G/N Y Y Y ? N TP-Link's driver TP-Link TL-WN723N v3 USB 2.0 0bda-8179 RTL8188EUS B/G/N Y Y Y ? N TP-Link's driver TP-Link TL-WN823N v1 USB 2.0 0bda-8178 RTL8192CU B/G/N Y Y Y ? N TP-Link's driver TP-Link TL-WN823N v2 USB 2.0 2357-0109 RTL8192EU B/G/N Y Y Y ? N TP-Link's driver TP-Link TL-WN823N v3 USB 2.0 ????-???? ???? B/G/N ? ? Y ? N TP-Link's driver Asus USB-AC56 USB 3.0 0b05-17d2 RTL8812AU A/B/G/N/AC ? ? ? ? N Asus's driver Asus PCE-AC66 PCIe x1 14e4-43a0 BCM4360 A/B/G/N/AC Y Y Y Y Y - Asus PCE-AC68 PCIe x1 14e4-43a0 BCM4360 A/B/G/N/AC Y Y Y Y Y - TP-Link TL-WN781ND v1 PCIe x1 168c-002b AR9285 B/G/N Y Y * * N DSDT/Atheros40 patch TP-Link TL-WDN4800 PCIe x1 168c-0030 AR9380 A/B/G/N Y Y * * Y - TP-Link Archer T9E PCIe x1 14e4-43a0 BCM4360 A/B/G/N/AC Y Y Y Y Y - NB: Patching means adding the PCI ids of the listed card to the Info.plist file found inside the listed kext. In rare cases, binary patching may also be necessary. For some cards, DSDT Patching can be a suitable and permanent alternative to kext patching (no need to repatch a kext after OS X updates and upgrades or new installations). For instance, in the case of the Atheros AR5B95 card (chip AR9285 168c,2b), adding compatibility with a chip known to be supported OOB such as AR9380 168c,30 or AR9280 168,2a (as found in the vanilla Atheros40 kext) in a _DSM method for the identified DSDT device does the trick once and for all since it'll make the OS load the associated kext: Device (<YourDevice>) // Identified wireless device through IORegistryExplorer (usually: ARPT) { ... ... ... Method (_DSM, 4, NotSerialized) // Device Specific Method for the wireless card { Store (Package () { "model", Buffer (0x1E) { "Atheros AR5B95 b/g/n Wireless" }, "device_type", Buffer (0x08) { "AirPort" }, "built-in", Buffer (One) { 0x00 }, "name", Buffer (0x10) { "AirPort Extreme" }, "AAPL,slot-name", Buffer (0x09) { "Internal" }, "compatible", // Declares compatibility with a device Buffer (0x0B) { "pci168c,30" // PCI id of device supported OOB } }, Local0) DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0)) Return (Local0) } } ` In the same respect, in the case of the Broadcom BCM4322x cards (e.g.: chip BCM43225 14e4,4357) or BCM4352 cards (14e4,43b1), adding compatibility with a chip known to be supported OOB such as BCM94360 14e4,43ba or 14e4,43a0 (as found in the vanilla AirPortBrcm4360 kext or AirPortBrcmNIC) in a _DSM method for the identified DSDT device does the trick once and for all since it'll make the OS load the associated kext: Device (<YourDevice>) // Identified wireless device through IORegistryExplorer (usually: ARPT) { ... ... ... Method (_DSM, 4, NotSerialized) // Device Specific Method for the wireless card { Store (Package () { "model", Buffer (0x23) { "AzureWare AW-NB290H b/g/n Wireless" }, "device_type", Buffer (0x08) { "AirPort" }, "built-in", Buffer (One) { 0x00 }, "name", Buffer (0x10) { "AirPort Extreme" }, "AAPL,slot-name", Buffer (0x09) { "Internal" }, "compatible", // Declares compatibility with a device Buffer (0x0B) { "pci14e4,43a0" // PCI id of device supported OOB } }, Local0) DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0)) Return (Local0) } } ` Broadcom BCM43224-based cards with id 14e4:4353 (e.g.: DW1520) are subject to whitelisting in AirPortBrcm4360 kext. Wireless will only work if using the SMBIOS of a supported Mac model or after binary patching the kext to inject the Mac board-id of the desired SMBIOS. See our patching guide on the matter. ________________ 1 AR946x (168c,34), AR9485 (168c,32) and AR9565 (168c,36) work to some degree (i.e. not 100%) with alternative (re-written) Atheros40 driver as posted at InsanelyMac by Chunnann. Further patching facility posted here. These cards appear very poorly supported to plain unsupported from High Sierra. They are NOT recommended. 2 DW1520 (14e4,4353) is known to suffer from frequent and repeated wireless disconnections when plugged into mini PCIe-only slot and built-in Bluetooth is enabled. This may even lead to wireless turning off. This has been noticed on Dell Latitude E6x20 and E6x30. Wireless works Ok once built-in Bluetooth is disabled in BIOS or, as stated by wl_michael, if the card is fitted into combo PCIe/USB slot such as WWAN. 3 DW1820A and other BCM4350-based cards are supported. See our BCM4350 guide for these cards. * See top of post for Mojave and Catalina
  23. 2 points
    Like this Add add the compatible device like this. You'll need to find you device location. If you have DW1560, then you can remove the pci-aspm-default
  24. 2 points
    @Chandara It is exactly the same as yours, with only RAM 8 gigs and WiFi AR5B95. Yes you can use my EFI and chances are you will have to create your own USBPorts.kext.
  25. 2 points
    Better later than never... As explained in past system/model-specific threads, there are further patches that may be used to modify the framebuffer memory size (useful on Latitude E6x30) and the VRAM allocation (nice to increase). Those parameters are defined in the 2nd line of the sample Capri layouts we've illustrated throughout this thread (bearing in mind the reversed byte order of kexts' binary code). For instance: LoRes mobile layout 0x01660003: 03006601 01020402 00000004 00000001 00000060 10070000 HiRes mobile layout 0x01660004: 04006601 01030101 00000002 00000001 00000060 10070000 Desktop layout 0x0166000a: 0A006601 00020302 00000002 00000001 00000060 10070000 Desktop layout 0x0166000b: 0B006601 00020302 00000002 00000001 00000060 10070000 1) Framebuffer memory size: This is defined in the 4th 32bit parameter of the layouts. Default value is 0x01000000 (reversed code 00000001), i.e. 16777216 in decimal which, when divided by 1024*1024 (=1MBytes), equates to 16MB. Some laptops such as the Dell Latitude E6x30 models suffer from corrupt/garbled display on screen unless this value is reduced to 8MB, i.e. 0x00800000. The patch required to change this is: Find: xxxxxxxx [...] xxxxxxxx 00000001 xxxxxxxx [...] xxxxxxxx Replace xxxxxxxx [...] xxxxxxxx 00008000 xxxxxxxx [...] xxxxxxxx For instance, to reduce the FB mem. size of layout 0x01660003 to 8MB, use this patch: \/\/ Find: 03006601010204020000000400000001 Replace: 03006601010204020000000400008000 /\/\ 2) VRAM allocation: This is defined in the 5th 32bit parameter of the layouts. In most recent versions of OS X/macOS, the default value usually is 0x60000000 (reversed code 00000060), i.e. 1610612736 in decimal which, when divided by 1024*1024 (=1MBytes), equates to 1536MB (i.e. 1.5GB). This is shared memory and systems with, say, 8GB of RAM, may want to increase this. The patch required to do this is: Find: xxxxxxxx [...] xxxxxxxx 00000060 xxxxxxxx [...] xxxxxxxx Replace xxxxxxxx [...] xxxxxxxx 000000YY xxxxxxxx [...] xxxxxxxx -> where YY = desired VRAM Qty Reminder: 256MB = 1000 0000 in hex 384MB = 1800 0000 in hex 512MB = 2000 0000 in hex 768MB = 3000 0000 in hex 1024MB = 4000 0000 in hex 1536MB = 6000 0000 in hex 1792MB = 7000 0000 in hex 2048MB = 8000 0000 in hex For instance, to increase VRAM allocation of layout 0x01660003 to 2048MB (i.e. 2GB), use this patch: \/ Find: 0300660101020402000000040000000100000060 Replace: 0300660101020402000000040000000100000080 /\ Naturally, those framebuffer modifications can be combined in a single patch. For instance, to reduce FB mem. size to 8MB and increase VRAM to 2GB, layout 0x01660003 is patched as follows: \/\/ \/ Find: 030066010102040200000004000000010000006010070000 Replace: 030066010102040200000004000080000000008010070000 /\/\ /\
  26. 2 points
    So what's not working? Trackpad: use Alps touchpad kext by Dr. Hurt. You can find it in R&D section Wifi: What does it have? Intel is not supported. Look in R&D section for list of supported devices Audio: Make sure you have latest Lilu.kext & AppleALC.kext and set layout-id to 11 Battery status: Make sure you have SMCBatterymanager.kext if you're using VirtualSMC or ACPIBatteryManager if you're using FakeSMC.kext Post debug file if you need further assistance. Can't help you blindly not knowing what you have
  27. 2 points
    Last update: 17 Sep 2017 UPDATE: 17 - 09 - 2017 Just wanted to clear few things about my commitments to community, and development on my projects which has been going slow due to my personal life as I have been hit really hard since an year, and I am trying to sort out personal things still. So decided to take timeout on my commitments to my projects and put my attention on personal life first. Don't expect any regular updates on this project and others projects of mine till end of this year 2017. It does not mean I will not be working, and it is just that I won't post any update or respond to you all unless I have something worth to share. I know many of you are disappointed with me and some of my choices/decisions for the last one year, but believe me I had no other option and good reason for that. So your patience will be rewarded properly once I have started releasing updates as I have big plans and willing to commit myself to long term development, and I apologize for not keeping up with promises so far. In case I fail to keep up like I promised above, then I will give up and release all of my work to others to continue. Hope you understand and support me with beta tests when I need them Thanks Hi everyone, This is a multitouch driver for ELAN, FocalTech and Synaptics touchpad for Mac OS X based on the documentations available and some ideas from VoodooPS2, ApplePS2 and Linux open source code. I have successfully accomplished everything so far and added many new features to take advantage the touchpad completely to make it close to Apple touchpad in every way. Also my driver is implemented with my own universal logic for all the features, so it can be adapted to all touchpads easily and I'm still improving these to achieve even better results. My driver supports every hardware version of ELAN touchpads except version 1 (which is too old and can't find in existing notebooks will support that if i get some testers), mostly all available FocalTech touchpads and Synaptics touchpads (still experimental) with firmware version v7.5+. NOTE: For Synaptics, it was developed based on my touchpad hardware i have, so support is limited to touchpad with firmware version 7.5+ only, but will try to improve support other hardwares also if users interested in my features and help me with beta testing. FOR BUG REPORTING: Please read the below threads which explain the features after installing the driver, so you can understand and learn how to use every feature. If anyone still have doubts/issues then PM me to get help from myself (or) post them in other thread about issues so others can help you. I will respond to you mostly during weekends only for some time. FEATURES DETAILS: (UPDATED FOR v4.6) Touchpad features: Click here to learn Keyboard features: Click here to learn Supports OS X version 10.6 or later (10.6 support is only from v4.4) For Prefpane, try to install the version from this link, and add the prefpane to start up items: http://www.hackintosh.zone/file/997-correct-preference-pane-trackpad-macos-sierra/ UPDATE: 06-06-17 Hi everyone, It has been long time since I have given you all an update on my development. The reason for this was I had a pretty rough personal life and busy time in my job last few months, so I was really under big stress and had busy days which did not allow me to do any progress on my projects. Good news is that I was able to sort some of my issues, and find some time to continue my projects again. I have already done some analysis on my project, and figured that I had to do some major code rewrite (most of the code was depending around work arounds which are not optimized well for the time being back then) in order to better support future hardwares and also improve features with ease. My plan is Setup a way to support and track bugs from users Setup a way to gather feedback from users Re-build the project from the scratch with good design for cross-platform support in mind, to support multiple touchpad vendors and interfaces (thinking about I2C) as universal driver Refactor the project code with as much clean code (so when I make it open others can understand) as possible of mine from the scratch Finish basic features (Keyboard and Mouse emulation) Integrate basic vendor specific features Develop and Integrate basic prefpane of mine Release first beta to test Integrate and implement my old driver features one by one for better stability Update prefpane for new features and release another beta Update and improve support for newer hardware based on linux and other sources Finish integrating all the features of old driver by reviewing each one with community feedback Add new features and improve it's stability and performance I have big list of TODO's, but I promise this time that I will try to finish each of them as soon as possible with a beta release happening very soon before the end of this month in best case. Understand your patience is really needed here, as I do not want to rush and have limited time of mine. Also, I am gonna give weekly update on my progress if possible when I have finished my milestones. I will try to respond to your PM during weekends, and if you want to be beta tester then send me your skype ids with GMT time via PM. One more thing, current version of my driver is deprecated and so will not be continuing this. But, I will try to give you some support if there is a need before I finish my new version of driver for any issues which are not big enough for time being. Thanks for your support and co-operation. PS: Sorry for those who want my project to be open sourced now, as I cannot do that until I finish above TODO's. Hope you understand, and support me as I really worked hard on this project. I have worries to get this open right now, and understand that with more people development can progress faster but opening this right now might create issues and end myself supporting to the development in the long run due to fragmentation. I would request you to go through plist editing for controlling the features (as I have a lot of them and its important users to know about those details, because it will allow the driver to be tweaked as you want and my default values are not going to be best for every touchpad or user) for now (will make my own prefpane very soon within 3 months, and its a promise). Going to update my thread which details the features every week one after another for keeping it updated with latest version. Version v4.7 beta 5 (10 - 12 - 2016) (work in progress, available to try from attachments). Added back feature multi finger drag due to users request (can be dragged using 1-3f, Note: This drag wont be as smooth as 1f because the data is not as good as 1f in 2-3f which is why I stopped working on this long time ago, but currently it works nicely and usable in my touchpad. So its usage varies to each touchpad). You have to hold fingers for 2-3 sec at fixed position and move to trigger drag. Improved support for Sierra Support for new style prefpane (most of the features wont control my feature, but I will fix them by next weekend to match them) [Drag, scroll, double click speed can be controlled inside Accessibility Settings->Mouse & Trackpad] [Experimental] USB mouse can now stop trackpad if you enable Accessibility setting of Ignore Trackpad [Works only in 10.10 or lower (?). Will find a way for new OS X versions asp] Improved scroll inertia with more control options in Plist to choose Fixed Sierra Caps Lock bug using a workaround Fixed a bug with some new ELAN touchpads which have issues with virtual buttons acting weird if pointing was enabled at button area, so added option to diable/enable this in plist Fixed sierra OS X functions like Launchpad, Dashboard, Mission control etc., which are not working by redirecting to new keyboard shortcuts. (Needs to be configured at Keyboard shortcuts) Updated support for Asus keyboard backlight with two levels Several minor bug fixes and improvements And more to come as am still looking at improving others things that are buggy and also using feedback from users Version v4.6.5 Released Major code optimizations Updated support for 10.12 (Still some Fn keys wont work, will try to fix close to release) Added plist options to control Apple Trackpad prefpane values for 10.12 Several bug fixes and improvements Version v4.6 Fixed CapsLock key change plist option Fixed a firmware bug in ELAN v3 hardware Updated driver to accept new revisions of ELAN Touchpad to be recognized as Version 4 Added plist option to disable the touchpad when LID id closed (Enable back auto when its opened)) which will stop strange behavior from touchpad when using HDMI in some systems. Pointer acceleration enhancements (new plist options to control) Partial support for the extra buttons and track point from Synaptics trackpad Improved support for synaptics Updated documentation for features Several minor bug fixes and optimizations Version v4.5 Added new plist option to control touchpad edges dead zone Added plist option to change 2f and 3f tap default actions Added option to tweak pointing acceleration Added 4f pinch gesture and plist option (ELAN and Focaltech) Updated plist options to better organize Improved 2f dragging in clickpads Improved edge swipes Fixed synaptic touchpad sleep issue seen in some systems Fixed some keyboard bugs Several improvements, minor bug fixes and optimizations Version v4.4.5 : Improved support for Synaptics touchpads (Clickpad working fine now) Updated support for new ELAN touchpads Improved edge swipes Fixed a bug with Karabiner app to allow mapping Several bug fixes and optimizations Version v4.4 : Released (For Asus keyboard backlight auto off, use updated DSDT patch and v2.5 Fn keys kext) Improved support for Synaptics touchpad (Clickpad still have some issues so i need beta testers) Improved support for some new ELAN and Focaltech touchpads Improved pointer acceleration Reworked scrolling Improved Swipes, Zoom and Rotations Added more plist options to tweak the gestures and option to control delay after sleep Added GIGABYTE Fn key mode layout Added support for 10.6 (32bit build) Fixed several bugs in both keyboard and Touchpad Optimizations Version v4.3 : Added support for Synaptics touchpads (Firmware v7.5+) found in new laptops but still its experimental for others as it has not been tested on many laptops. (Tested only on Lenovo Z50-70 and G400) Added support for unsupported touchpads to work in enhanced mouse mode without multi touch Improved support for Focaltech and ELAN touchpad (especially ELAN v2) Improved pointing and scroll with new smoothing features and other improvements which can be controlled in plist Improvements and optimizations for all features Added plist option for keyboard to make Num Lock into clear instead of soft controlled num lock mode Added Fn keys mode layout for Lenovo Added support for ACPI brightness controls from EC calls (You have to use DSDT patch) Fixed many bugs For the complete change log of all the updates follow this thread: https://osxlatitude.com/index.php?/topic/1966-elan-touchpad-driver-issues/ FEATURES OF ELAN v4 HARDWARE, FOCALTECH and SYNAPTICS: (Supports up to five fingers touch) Mouse mode with Virtual Buttons Left, Right and Middle Tapping - Up to 5 fingers Clicking - Up to 5 fingers Dragging : Tap to release and Finger Lift ⃠Left Button Drag, Double Tap Drag, Single Tap Drag and Click Drag Corner Tapping Scrolling - Single finger Edge and Two Fingers swipe Continuous, Linear, Sling and Inertial scroll effects Finger Press - Up to 5 fingers Swiping - Edge, Three and Four Fingers Zoom - Two fingers pinch zoom, OSX Zoom with Keyboard 4 (Elan, Focaltech) & 5 fingers Pinch gesture Rotations - Arc and Swipe Rotations Accidental Input/Palm check when typing Fn Keys Mode Features Toggle Full customization FEATURES OF ELAN v2 and v3 HARDWARE: (Supports up to three fingers touch) Mouse mode with Buttons Left, Right and Virtual Middle Tapping - Up to 3 fingers Dragging - Tap to release and Finger Lift ⃠Left Button Drag, Double Tap Drag and Single Tap Drag Corner Tapping Scrolling - Edge Scroll and Two Fingers Continuous, Linear, Sling, Circular and Inertial scroll effects Finger Press - Up to 3 fingers Swiping - Edge and Three Fingers Zoom - Two fingers pinch zoom, OSX Zoom with Keyboard Rotations - Arc, Circular and Swipe Rotations Accidental Input/Palm check when typing Fn Keys Mode Features Toggle Full customization HOW TO INSTALL: Remove any existing "ApplePS2Controller, VoodooPS2Controller, AppleACPIPS2Nub, ApplePS2Keyboard and old Elan Touchpad" kexts if you have already installed from the HDD '/System/Library/Extensions ', '/Extra/Extensions', and '/System/Extensions/Library/myHack.kext/Contents/Plugins/' (if you used myHack USB installer for OSX). If you use USB installer to boot (used to install OSX), then you have to remove the above kexts from USB '/Extra/Extensions'. Install the Kexts (Recommended to use Kext utility for installing) inside the attached zip file using any kext installing methods (In clover, some systems may have problems with kext injection, so try to install them to System/Library/Extensions in that case). 
 ​ NOTE: From v3.3, there is only one kext as my driver in the attached zip file. For Support PM me or POST here . I may respond slowly sometimes due to busy life. NOTE: Please don't mirror my files at other places, let the people know about this thread for the latest version and support. NOTE: I've worked very hard on this driver (especially ELAN v2, 4 and Focaltech without hardware) and will try to continue support in future. I do the development everyday with some time dedicated to this and many other projects. But i need your support so i can get more time to spend on these projects for improvements. Also we maintain this website without ads for all of you and it costs a bit for us to host. IF POSSIBLE PLEASE MAKE A DONATION BY CLICKING BELOW PAYPAL DONATE BUTTON FOR ME Paypal: FOR WEBSITE DONATE HERE: http://www.osxlatitude.com/donate/ THANKS FOR YOUR SUPPORT I would like to thank following people for beta testing the driver and providing valuable feedback: Leon, Ramalxlama, Shin zon, Sherlocks, Dragon, Ðнтошка, Thomas benhamou,68x, Eli and many others. SOURCE: Project source code: https://github.com/E...Touchpad-Driver I am still doing some major work with beta testers to improve the features and stability, so I cannot update my git until its done, because it may allow others to modify and distribute their own version which can miss my changes and also worried about something else too which I do not want to mention here. I want to support this project for very long time and did spend hundreds of hours so far with testers (without hardware) and implemented many of the features myself from the scratch. So, I deserve and have rights to not to update my project source until I feel confident. The base of the Apple PS2 open sources I have used for my project are pretty much same which you find in the source from my above git link and rest of the changes from that are based on documentation and my own ideas. CREDITS: ELAN - Arjan Opmeer for ELAN linux documentation/source FocalTech - mgottschlag (github) for linux source Synaptics - Synaptics official documentation and linux source I would like to thank the VoodooPS2 team (Slice, King, rehabman and many others who contributed to the VoodooPS2) for ideas, Apple for their PS2 open sources which i've used as base for my driver and linux sources for the touchpad initialization and packet info. SmoothMouse 1.0.5.zip mouseaccelerationpref11d.zip Apple Keyboard Layout ID.rtf ElanTouchpad_v2.8.3.zip ELAN_v3.8.5_Final_Upd.zip ELAN_v4.0.5.zip SmartTouchPad_v4.2_Final.zip SmartTouchPad_v4.3_Final.zip SmartTouchPad_v4.4_Final_64bit.zip SmartTouchPad_v4.4_Final_32_64bit.zip SmartTouchpad_v4.4.5_32_64bit.zip SmartTouchpad_v4.4.5_64bit.zip SmartTouchPad_v4.5_Final_64bit.zip SmartTouchPad_v4.6.zip SmartTouchPad_v4.6.5.zip SmartTouchPad_v4.7 beta 3.zip SmartTouchpad v4.7 beta 5.zip
  28. 2 points
    HI, Herewith my EFI for Acer Swift 3 (SF314-54G) success install Mac OS Catalina 10.15.5 (Build 19F101) with OpenCore 0.5.8. Specs : Processor : Intel® Core™ i3 7020U 14″ Full HD display iGPU : Intel UHD 620 eGPU : NVIDIA MX150 (disable via SSDT) RAM : 12 GB (4 GB internal RAM + 8 GB Samsung DDR4 2400 MHz) WIfi Card: Intel 7265 (bluetooth working properly, not yet test using intelwifi kext) USB Wifi : TL-725N Storage : 1TB HDD Touchpad : ELAN 502 Note: Brightness button not yet function due this is my sister laptop and she already taken it. EFI-Acer Swift 3.zip
  29. 2 points
    Enabling 4K External Display I had been seeing some queries about enabling 4K display for E7440 lately so I decided to spend some time on the matter. Unfortunately I don't own or have access to a 4K display but I do have a 2K display to test with. As expected the default settings can only display as high as 1080p. I did some experiments following existing guides found here in the forum and was successful getting 2K to display, I believe it should work for 4K as well. So here are the steps required: 1) Raise the DVMT pre-alloc from 32mb(default on this model) to 128MB in the BIOS. Since you can't access this setting from Dell's BIOS, you'll need to use the EFI shell to accomplish this. See my guide here. Below are the locations found for DVMT Pre-allocated and CFG Lock Set DVMT @ 0x255 to 0x4 Set CFG Lock @ 0xC8B to 0x0 (not sure if this necessary, but it didn't break anything) Here are the commands from EFI Shell: setup_var 0x255 0x4 setup_var 0xC8B 0x0 2) Update Config.plist file from bootpack above under Devices/Properties/PciRoot(0x0)/Pci(0x2,0x0) the following: framebuffer-cursormem = 00000003 framebuffer-fbmem = 00000003 framebuffer-stolenmem = 00000008 uncomment #framebuffer-unifiedmem by removing the # in front (Optional) That's it. FYI, the DVMT & CFGLock value will restore to default if you ever select Load Default in the BIOS. You'll need to redo the steps in #1 Updating BIOS does not remove the settings. Resources: https://osxlatitude.com/forums/topic/10267-understanding-and-patching-framebuffer-haswell/ https://osxlatitude.com/forums/topic/8723-enabling-dvidphdmi-and-increasing-vram-with-intel-haswell4th-gen-hd420044004600etc-igpu/
  30. 2 points
    hi @Daniel PN You can try my update OC 0.6.0. Enter your own Serial Number and your own device properties, I'm only put graphics and audio on properties. SD Card reader is disable in BIOS due I don't have SD Card for testing it. Wifi card swap form DW1708 to BCM943224PCIEBT2 and Mac OS Using Catalina 10.15.5 (Build 19F101), and touchpad is ALPS V8. My system is touchscreen and working properly with this EFI. I2C kext still using release 2.3 due last time when update to 2.4, the touchscreen is not working. FYI, since I'm use Opencore (0.5.6 - 0.6.0) on my e7270 must add boot option manualy in BIOS. EFI 7270 OC 0.6.0.zip SSDT on this EFI is mixed to 1 file. If you want separated SSDT herewith the file ACPI separated.zip
  31. 2 points
    Specifications: Intel 6th generation Core i5-6200U 2.3 GHz, up to 2.8 GHz with Intel Turbo Boost Technology, 3 MB cache, 2 cores Integrated Intel HD Graphics 520 Non touch 35.6 cm (14 in) diagonal LED backlight FHD Slim eDP SVA Anti-glare (1920 x 1080) with camera System can be configured with a hard drive and M.2 SSD drive / NVMe 8192 MB total system memory (8192 MB x 1) Up to 32 GB - DDR4 PC4-17000 (Transfer rates up to 2133 MT/s) Intel Wireless-AC 3165 802.11 a/b/g/n/ac (1 x 1) WiFi and Bluetooth 4.0 combo (non-vPro) HP Module with NXP NFC Controller NPC100 Intel Ethernet Connection I219-V 10/100/1000 Ethernet Synaptics Touchpad Audiio Conexant CX20724 - VendorID: 0x14f150f4 Integrated HD Webcam (1) USB 3.1 Gen 1 charging (1) USB 3.1 Gen 1 (1) USB Basic Type-C (1) DisplayPort (1) VGA (1) RJ-45/Ethernet (1) Docking connector (1) Headphone/microphone combo (1) AC (1) External SIM (1) SD media card reader, supports SD, SDHC, SDXC Working: full graphics acceleration on Intel HD520 iGPU, including brightness control (F5 and F6) multi-display with DisplayPort OOB, VGA and HDMI over USB Type-C audio, microphone input and headset output (F8 and F9) - Mute button not working GigEthernet LAN connection wireless and bluetooth with any compatible card (a DW1560 in my case, no Whitelisting) left and right USB ports including USB Type-C integrated webcam (OOB) CPU power management sleep (Lid, Energy Saver settings, Apple menu, PWR button) & wake (Lid, PWR button) battery management (with SMCBatteryManager v1.0) keyboard and touchpad (with VoodooPS2Controller v1.9.2) keyboard backlight (Fn + F3) touchpad including tap-to-click, scrolling, mouse buttons (can be disable with prt scr key) Partially working: RTS522a microSD card reader (read-only mode) - after sleep, need to eject and reinsert New updated kext allow read and write Not working: TrackStick Finger Print reader Wifi button Mute button (grayed out) BIOS Settings: Installation: Follow the standard UEFI Clover guide Replace contents to /EFI/Clover after installing Clover HP840_G3.zip Updates: Added VoodooSMBUS for better touchpad experience, most gestures work! HP840G3_BetterTouchpad.zip Add HPFanReset.efi to /EFI/Clover/drivers/UEFI HPFanReset.efi.zip Post install: Install CsmVideoDxe.efi to fix stretched Clover boot screen using Clover Configurator. The version from Clover installer does not work. Change BIOS settings for Secure Boot Configuration Configure Legacy Support and Secure Boot = Legacy Support Disable and Secure Boot Disable Note: Files tested on Catalina, Mojave, High Sierra, El Capitan ( Just need to add boot arg -no_compat_check) Credits: Rehabman for hot patched files Sinetek /Cholonam for Sinetek-rtsx (SD Card reader) Leo-laps / 1Revenger1 for VoodooSMBUS & VoodooRMI
  32. 2 points
    As @arsradu suggested, just update to latest Clover and update the kexts to the latest. If you have 3rd party kexts in /L/E make sure to update those as well, repair permission and rebuild cache. See if it still boots. If no issue, then continue upgrading. For sure you'll need a minimum of Clover v5107 to boot 10.15.4. I would recommend just upgrading to the latest v5118 at the time of writing this.
  33. 2 points
    A few of us with old C2D/C2Q platforms (mostly desktop) experienced CMOS reset since updating to 10.15.4. During troubleshooting, the issue was pinpointed to 10.15.4's new boot.efi file (located in /S/L/CoreServices) which, as many of us noticed, was displaying some new info when booting in verbose mode. Initially, replacing 10.15.4's boot.efi file with that of an earlier Catalina release or even an earlier macOS version was found to get rid of the problem without adverse affect on booting Catalina 10.15.4. However, this only worked for Hackintosh systems running Clover, not for systems running OpenCore. 10.15.3_boot.efi.zip File ownership needs to be re-adjusted to root:wheel upon replacement: sudo chown 0:0 /S*/L*/CoreServices/boot.efi Update: 15 April 2020 - - - - - - - - - - - - - - - Following further troubleshooting with vit9696, telepati and a few others, vit9696 worked out a temporary workaround for OpenCore in the form of a 5-bytes NVRAM variable wake-failure set to 00 00 00 00 00. All details and explanations are available here. For Clover users, this workaround alternative to replacing boot.efi can implemented as follows in Terminal: sudo nvram wake-failure=%00%00%00%00%00 Of course, this needs NVRAM to be working properly on the target Hack. For Hacks with no natively-supported NVRAM, it is required to install EMUVariableUEFI.efi Clover module + RC scripts on the Catalina boot volume. Once the variable is set and the system rebooted to take it into account, no more CMOS reset on rebooting from 10.15.4.
  34. 2 points
    use BrcmPatchRAM3.kext for Catalina Also make sure you have updated Lilu, Whatevergreen, and AppleALC to the latest. Make sure you don't have these same kexts in /L/E or /S/L/E that might be of different version.
  35. 2 points
    It would be very cool to open source this since the dev doesn't seem very interested in continuing to develop it, would mean a lot for us ELAN Touchpad Users.
  36. 2 points
    Farewell old girl.... she was the last bastion of our original "D" series that started the whole OSXL endeavors..
  37. 2 points
    Here, replace into /EFI/Clover 7280_HD520_Catalina.zip
  38. 2 points
    Last update: 22 Mar 2020 EDP being in semi-permanent revamp, here are full packs for the Latitude D620/D630 series. The packs do not require any subsequent EDP tuning at all, they provide everything required to obtain a fully working system (CPU power management, graphics, LAN, audio, keyboard, trackpad), non-OOB wireless, bluetooth and any other devices excluded of course. However, some manual tuning for proper Sleep/Wake operation is required: setting hibernation mode to plain old sleep and deleting any eventual sleep image file. This is done through the following Terminal commands upon final OS X installation: sudo pmset -a hibernatemode 0 sudo pmset -a hibernatefile /dev/null sudo rm -f /var/vm/sleepimage Vanilla support stops at Lion 10.7.5 for all Intel GMA based models and the D620 nVidia due to GPU support limitations. For those systems, ML may be installed and tuned back to 32bit operation through MLPF hack. Look at the Dell installation guides forum subsection for MLPF'ed ML guides and packs. It's not 100% bug-free though... Only the D630 nVidia supports vanilla installation of Mountain Lion, Mavericks, Yosemite, El Capitan, Sierra and High Sierra (Sierra & HiSie only with Penryn CPUs). For all models, read the Performance tuning thread for CPU + GPU tuning if required but the FakeSMC kext included in the packs below brings it all. D620 GMA950 LoRes (WXGA 1280x800): D620_GMA950_LoRes_10.6.8_Pack.zip D620_GMA950_LoRes_10.7.5_Pack.zip D620 GMA950 HiRes (WXGA+ 1440x900): D620_GMA950_HiRes_10.6.8_Pack.zip D620_GMA950_HiRes_10.7.5_Pack.zip D620 nVidia Quadro 110M (all res): D620_NV110m_10.6.8_Pack.zip D620_NV110m_10.7.5_Pack.zip D630 GMA X3100 LoRes (WXGA 1280x800): D630_X3100_LoRes_10.6.8.zip D630_X3100_LoRes_10.7.5_Pack.zip D630 GMA X3100 HiRes (WXGA+ 1440x900): D630_X3100_HiRes_10.6.8.zip D630_X3100_HiRes_10.7.5_Pack.zip D630 nVidia Quadro NVS 135M (all res): D630_NV135m_10.6.8_Pack.zip D630_NV135m_10.7.5_Pack.zip D630_NV135m_10.8.5_Pack.zip D630_NV135m_10.9.5_Pack.zip D630_NV135m_10.10.5_Pack.zip D630_NV135m_10.11_Pack.zip D630 nVidia Quadro NVS 135M + Penryn C2D CPUs (all res): D630_NV135m_10.12_and_10.13_Pack.zip NB: MyHack highly recommended for installation of Snow Leopard, Lion, Mountain Lion and Mavericks. Use myHack v3.3.1, except for SL which requires v3.1.2 (there's a bug related to SL in v3.3.1). For Yosemite and beyond, we recommend manual USB installer creation using instructions that have been detailed in numerous guides posted here. NB: For Chameleon-based Yosemite installations (i.e. no Clover or otherwise), not all kexts load from /E/E. Eg: VoodooHDA + HDADisabler or lspcidrv. In such cases, copy the kexts to /L/E, repair permissions and rebuild the cache with the following Terminal commands: sudo chmod -R 755 /Library/Extensions sudo chown -R 0:0 /Library/Extensions sudo touch /Library/Extensions sudo kextcache -Boot -U / Update to Chameleon r2468 is recommended for proper hardware support such as good CPU detection. Chameleon-2.3svn-r2468.pkg.zip NB: For Enoch-based Yos/EC/Sierra installations (recent Enoch versions such as r2795 and beyond for instance), you may use a kernel.plist file in /Extra with parameter KernelBooter_kexts set to Yes to load kexts from /E/E directly. Those kexts will not natively be considered for prelinked kernel/kext cache generation so boot time will be a little slower. To maximise boot time, you can either move kexts from /E/E to /L/E or copy them from /E/E to /L/E and set KernelBooter_kexts to No. You will then repair permissions and rebuild the cache as detailed above. macOS Sierra and later can only be installed on D630 nVidia models fitted with a Penryn FSB800 C2D CPU (e.g.: T6xxx, T8xxx, T9xxx). Enoch-rev.2839.pkg.zip
  39. 2 points
    Okay, He just sent it to me, this is what is currently running on his laptop. Hope this gets you going. You will still need the loadapfsdriver.efi at the root of your flash drive. CLOVER.zip
  40. 2 points
    As a nice complement to our wireless inventories, there's a pretty good summary of Broadcom BCM4350, BCM4352 and BCM4360 cards here: https://khronokernel-7.gitbook.io/wireless-buyers-guide/types-of-wireless-card/m2 By far and large, cards are size 2230 and Key A/E with very limited Key E models. As a recap: Broadcom BCM94360: Fenvi BCM94360NG Key A/E , size 2230 supported OOB Dell DW1830 Key A/E, size 3030 3 x antennas Broadcom BCM94352: Fenvi AC1200 Key A/E, size 2230 supported OOB Dell DW1560 Key A/E, size 2230 AzureWave AW-CB162NF Key E, size 2230 seems quite rare Foxconn T77H543 Lenovo 04X6020 Lite-On WCBN802B Key E, size 2230 Broadcom BCM94350: (see our dedicated guide on those) Dell DW1820A (Key A/E, size 2230) Lenovo Foxconn T77H649 (Key A/E, size 2230) Lite-On WCBN808B (Key A/E, size 2230)
  41. 2 points
    Just updated to Catalina. Thanks to Jake on the ECDV -> to EC DSDT fix. then it was just letting the Installer do its thing. thanks again Jake!
  42. 2 points
    Here is a full CLOVER folder for Catalina for the E5470/E5570 CLOVER.zip
  43. 2 points
    Try this bootpack, file patched from your Origin folder Replace into /EFI/Clover Replace your wifi with a DW1560 E470_Catalina.zip
  44. 2 points
    Hi Friends Install macOS Catalina on Dell Latitude E6440. Install with my uploaded EFI.zip. if problem with USB Ports, Block GenericUSBXHCI.kext in Clover. USBInjectall.kext and USBinjecter.kext not worked for me. SSDT.aml is Already Present in ACPI Patched Folder for Solved the USB ports Problem in macOS Catalina 10.15 Beta. I updated my Bios version to A-23 I Attached my EFI.zip and After install.zip Folders. and Pics Also. EFI.zip After Install.zip
  45. 2 points
    Hello everyone Thank you very much for your wonderful and useful forum I want share with you after long search and fixes my final EFI Partition for Dell Precision WS M6800 & M4800 and will work 99 % on any similar Model All files , Kexts , ACPI , Guide are all included in zip file linked below This my final EFI with alots of fixes and tweaks works for both High Sierra and Mojave only you will need Nvidia web drivers and Cuda to get fully working machine for graphic designing , video editing and 3D ... - Fully working everything , audio , Bluetooth, Brightness slider , card reader , mSata , ethernet , Wifi , Camera ,all USB 3 Ports and many more you will explore it yourself ...... - Bios Reset issue fixed - Optimus Graphic enabled - Use Intel HD only or Intel HD + Nvidia (if you want Nvidia only then disable Optimus in bios) - External Monitor use Nvidia - No black Screen when external monitor is connected - What is missing and doesn't work !!!! You will tell me - all fixes files and instructions are included ************************* UPDATED 30 JUN 2019 ************************ - Alots of Tweaks has been added to ACPI , config.plist and IntelFrameBuffer - USB 3 all ports fixed natively - KEXTS has been updated -Clover bootloader has been updated - Fans has been adapted by ACPIPoller.kexts and SSDT for more cooling and less noise - CPU and RAM Tweaks - No more Kernel Panic with release or security update - Clean DSDT , SSDT , plist - Alots of work, search and tests to get this result with this Laptop - Ready for Catalina ( wait for the official release and Hacks developers final fixes to be ready ) All Updated Files are here ( 50 MB) ; https://drive.google.com/file/d/107_34arPRYoiObJUCH9l7TG_tZsK2FOD/view Thank You ********************* 30 Nov 2018 Fix OLD .zip If you need any help or have any questions or issue please let me know in the Support section of the forum and I will reply as soon as possible Cheers
  46. 2 points
    30-06-2019 Update Attached Files in First Post ( Google Drive Link 50 MB ) This instructions is for Dell Precision m6800 (and similar Dell Precision Models - Experimental) Before you start Please note that : I am using Dell Precision m6800 with these SPEC : Intel I7 4900MQ 2.8 Mhz - Intel HD Haswell 4600 32 GB RAM Nvidia Quadro K3100M 4GB Samsung EVO 250 GB Dell DW 1560 WiFi and BT Adapter BIOS A25 ( Latest 30 Oct 2018 ) This Process has been successfully tested with High Sierra and Mojave 10.14.5 Both IGPU and DGPU are Working Together Correctly like a Desktop No Bios reset issue when reboot , Works with Dual Boot ( Win + OSX ) ******* Step By Step ******** 1- Reset BIOS to its default and Update it to A25 2- Modify BIOS setting ( Press F12 to see Options ) * Advanced Boot Options = Enable Legacy * Integrated NIC = Enable * Parallel Ports = AT * Serial Ports = Disabled ( If you are using Dock station then Enable it - Expermental ) * Sata Operation = AHCI * Drivers = Check all * Switchable Graphics = Enable Switchable Graphics * Secure Boot = Disabled * Virtualization = Disable 3- Create your OSX Installation USB ( Search How , its not my Topic ) * Then I recommend to install Clover bootloader to create EFI Folder on your USB (UEFI Method) 4- Once you create OSX Installation USB ; mount USB EFI PARTITION and DELETE EFI Folder 5- Decompress my attached files 6- On my attched files ; Find ( install Folder ) Copy EFI Folder and Paste it in your USB EFI PARTITION ( instead of deleted one in step 4) 7- Now you are ready to Install OSX for Dell Precision M6800 * Power On your PC * Press F12 to see Options * Select BOOT from ( your USB ) * Start Installation Process ( it will reboot several time during installation so press F12 each time to boot from your USB ) - search Youtube videos to see the installation process 8- Once installation done and you reach your OSX desktop *Copy my attached files to your Desktop and Eject USB * Mount your OSX Drive EFI PARTITION and delete ( EFI Folder if existed ) * On my attached files Find ( Boot Disk EFI ); copy EFI Folder and Paste it in your Drive EFI PARTITION instead of deleted one "same as step 6" 9- Now the last step ( very Important ) - on my attached files Find (L/E Folder) - use any method or tool to install ALL KEXTS to Library/Extensions - Rebuild kextcache and repair permissions - I recommend using Hackintool by @headkaze to install kexts and rebuild kextcache 10- Reboot your PC and check everything is working correctly ( Audio , Bluetooth , WiFi , Internet , USB 3 , Trim ... ) IF you are using Mojave ; No Cuda drivers available till now but Nvidia GPU works with 4k External Monitor via DP Fully Accelerated Qi-Ci , also you can Disable Bios graphics Optimus to disable Intel HD GPU and use only Nvidia GPU - The same thing with High Sierra except that Nvidia Web Drivers are available and Cuda are ready - I use this PC all time with 4k external monitor while laptop led screen is closen using external mouse and Keyboard for Graphic design and video editing; H264 with hardware acceleration is working but no H265 hardware acceleration I think due to Haswell limitation - also I've found useful app to disable CPU turbo boost . I use it sometimes to reduce CPU temp ( search google ) Note : in case you have booting troubles ; Try to change SMBIOS in config.plist to diffrent model as MacbookPro 10.1, MacBookPro 11.2, MacBookPro 13.1 also you can try iMac 14.2 ( works nicely with me I don't know why ) Little Tweak for CPU and RAM : go to CPU section in config.plist using clover configurator and add values to this sections according to your CPU frequency (Be careful) For example: - Add 2800 to "frequency mhz" if your CPU base is 2.8 mhz ( 2700 if 2.7 and 2100 if 2.1 , ...) - Add 99790 to "Bus speed khz" - Add 47 to "TDP" ( Look intel CPU spec page for your model to know more info about your CPU and TDP value for your CPU ) For example in my case https://ark.intel.com/content/www/us/en/ark/products/75131/intel-core-i7-4900mq-processor-8m-cache-up-to-3-80-ghz.html GPU Power Management: Delete my dAGPM.kext from clover/Kexts/Others and make your own Kext according to your SMBios ID to get the correct power management There is a tool developed by @pavo to generate your Kext and another method by @toleda search forum and google to know more about that Disable Nvidia GPU: If you want to disable dGPU and use only Intel HD 4600 drop SSDT-4600.aml to clover/ACPI/Patched . But in this case no external monitor will be working only internal Disable Intel HD GPU : If you like to use only Nvidia GPU so disable Optimus Graphics in Bios and you can use internal and external monitor USB 3 Ports Fixes : Please Modify The Info.Plist inside USBPorts.Kext to Match Your SMBIOS Find and change this text (iMac 14.2) change to (Your Model) every where in plist For Example (iMac 14.2) To (MacBookPro 11.2) Now All Your USB 3 Ports And Camera Will Work Correctly Have Fun Franckenstien 30 Jun 2019 SSDT-4600.aml.zip
  47. 2 points
    Nawcom's sort of disappeared from the Hackintosh scene but tribute can still be paid to him and his great tools. It sure is dated today but it did the business back in the days and greatly so. These may still be useful for those novices who want to setup a Hackintosh on a platform capable to run Snow Leopard but have no access to a Mac or an existing Hack. Snow Leopard remains the Mac OS X version from which many platforms can upgrade to subsequent OS X/macOS versions as long as their profile (SMBIOS) meets the requirements. Provided one has the Snow Leopard retail DVD or a USB key with retail SL restored to it, Nawcom's modCD or modUSB can be very useful to setup a temporary basic SL installation to work from. It does not have to be fully tuned up... Nawcom's tools are hard to find on the Net today, so here are copies it. I hope (and think) Nawcom's would not mind... OSX86_ModCD-032311-151021.zip -> rename from .zip to .iso and burn the image to a CD/DVD (can be done from Windows or Linux) OSX86_ModUSB.pkg.zip -> unzip this Mac app and run from OS X to create a bootable USB installer (cannot be used in Windows/Linux)
  48. 2 points
    Mojave Mojave Guide Bootpacks Replace into /EFI/Clover after you install Clover E7470_Mojave.zip FYI, kexts in bootpack is outdated Make sure to 1st upgrade kexts found under /EFI/CLOVER/kexts/Other if you encounter issue Common links for new kexts: https://github.com/vit9696/Lilu/releases https://github.com/vit9696/Lilu/blob/master/KnownPlugins.md https://bitbucket.org/RehabMan/ Note: 1) Post Install: Copy kexts in /EFI/Clover/kexts/Other/CopyToLE to /Library/Extensions. Repair permissions and rebuild cache 2) Enable this patch in Config.plist under KextsToPatch if you have: LiteOn, Plextor, or Hynix NVMe Hynix NVMe patch 10.13.x (Bit swap block size 0x10) -Syscl UPDATES Mojave 10.14.1 (18B75) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Install latest Clover prior to update Mojave 10.14.2 (18C54) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Install latest Clover prior to update Mojave 10.14.3 (18D42) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Install latest Clover prior to update Mojave 10.14.4 (18E226) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Install latest Clover prior to update Mojave 10.14.5 (18F132) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Install latest Clover/update kexts prior to update Mojave 10.14.6 (18G84) / (18G5033) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Install latest Clover/update kexts prior to update Repair permissions and rebuild cache
  49. 2 points
    OMG i just can't believe your are the best bro I swear your are the best < 3 It is working bro I love You , I love your forum I attached the final version from my clover thanks a lot 3558_A10_Patched_Final_Version.zip
  50. 2 points
    If you had been patching your own DSDT recently, you most likely encountered this common error dialogue when clicking on the 1st 2 errors, they'll take you to these set of codes To fix the errors, I created this patch which you can just apply with latest version of MacIASL This will fix all 3 errors listed above. Enjoy!
This leaderboard is set to Amsterdam/GMT+01:00
×
×
  • Create New...